Closed Bug 1078267 Opened 5 years ago Closed 4 years ago

Intermittent test_user_agent_updates.html | Test timed out. - expected PASS

Categories

(Core :: Networking, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox35 --- disabled
firefox36 --- disabled
firefox37 --- disabled
firefox38 --- disabled
firefox40 --- disabled
firefox41 --- disabled
firefox42 --- disabled
firefox43 --- fixed
firefox-esr31 --- unaffected
firefox-esr38 --- disabled

People

(Reporter: cbook, Assigned: miketaylr)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

Ubuntu VM 12.04 x64 Mulet mozilla-inbound opt test mochitest-5

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=2789445&repo=mozilla-inbound

03:58:38 INFO - 1153 INFO TEST-UNEXPECTED-FAIL | /tests/netwerk/test/mochitests/test_user_agent_updates.html | Test timed out. - expected PASS
Fun times, this still fails with test_user_agent_overrides.html disabled.
jim - this appears to be a test you added that is failing too much to be useful.

Can you take a look at it and disable if you cannot diagnose?
Flags: needinfo?(nchen)
No more whack-a-mole. Entire directory disabled on Android.

https://hg.mozilla.org/integration/mozilla-inbound/rev/37d6acec5205
See Also: → 1111137
Whiteboard: [test disabled on Android][leave open]
Ideally we can figure out why this is blowing up and get these tests reneabled before landing 1162099.
Blocks: 1162099
I think the reason this failed was the same cause for bug 1178760, described by jchen here: https://bugzilla.mozilla.org/show_bug.cgi?id=1178760#c7. Basically, the test assumed it could grab a ua-update.json from the profile but it never really did. 

That would explain never being able to get outside of waitForSave, and the timeout caused by:

https://dxr.mozilla.org/mozilla-central/source/netwerk/test/mochitests/test_user_agent_updates.html?offset=500#226-231

That was fixed by https://hg.mozilla.org/mozilla-central/rev/245bf6f33372, so I think these tests should be safe to enable now. Locally I can't get any timeouts, so I'm going to throw it at try.
Hey Jim, do you think the theory in Comment 153 is viable?
Assignee: nobody → miket
Attachment #8653046 - Flags: review?(nchen)
Forgot to link try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d96de6b3f2ab

Not conclusive proof given the hard-to-reproduce-iness of this bug, but green nonetheless.
Comment on attachment 8653046 [details] [diff] [review]
1078267.-Re-enable-netwerk-mochitests-for-Fennec.patch

Review of attachment 8653046 [details] [diff] [review]:
-----------------------------------------------------------------

Not sure why that would cause a failure only intermittently, but I think it's worth a try.
Attachment #8653046 - Flags: review?(nchen) → review+
Flags: needinfo?(nchen)
Thanks Jim. Unsure if we need the [leave open] whiteboard, but I didn't remove it.
Keywords: checkin-needed
Whiteboard: [test disabled on Android][leave open] → [leave open]
Adding r=jchen to commit message and carrying forward r+.
Attachment #8653046 - Attachment is obsolete: true
Attachment #8654085 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/61f9aefb8914
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [leave open]
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.