Location autocomplete popup displays JSON string after editing a search engine suggestion

RESOLVED DUPLICATE of bug 1070778

Status

()

Toolkit
Autocomplete
RESOLVED DUPLICATE of bug 1070778
3 years ago
3 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

35 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Steps to reproduce, tested in today's Firefox Nightly on Linux:

1) Type "foo bar" into the Firefox address bar.

2) Press the "down arrow" key to highlight the first autocomplete suggestion, which should be the default search engine (e.g. 'foo bar - Search with Google').

3) Type one more letter, like 'x'.

Expected results: Suggestion now reads 'foo barx - Search with Google'.

Actual results: Suggestion now reads 'Visit: { "url": "http://...",' followed by more JSON properties.

Note: I can reproduce this almost all the time, but not quite 100%.  I haven't figured out what triggers it to fail or succeed.
I think it's a dupe of bug 1070778?
The patch from bug 1070778 indeed fixes it for me.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1070778
You need to log in before you can comment on or make changes to this bug.