Update pip on supportadm.private.phx1 to at least 1.4

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mythmon, Assigned: gozer)

Tracking

Details

(Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/244] )

(Reporter)

Description

3 years ago
The version of pip installed on supportadm is version 1.3.1, which is about 14 months out of date at this point. In particular, it does not support installing from Python wheels. SUMO doesn't actually need wheels, but we would like to use options that only exist in wheel-supporting versions for consistency.

This is related to Bug 1074861.
Assignee: server-ops → server-ops-webops
Component: Server Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
QA Contact: shyam → nmaul

Updated

3 years ago
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1695]
(Assignee)

Updated

3 years ago
Assignee: server-ops-webops → gozer

Updated

3 years ago
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1695] → [kanban:https://webops.kanbanize.com/ctrl_board/2/244]
(Reporter)

Comment 1

3 years ago
When we upgraded to Python 2.7, we got this too.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.