WRMB:[quirks]Show Empty Table Cells STYLE background-color, and background-image

RESOLVED FIXED in mozilla0.9.6

Status

()

Core
Layout: Tables
P2
normal
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: bc, Assigned: karnaze (gone))

Tracking

({topembed})

Trunk
mozilla0.9.6
topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugscape: 94041] PATCH CANDIDATE_094)

Attachments

(6 attachments)

(Reporter)

Description

16 years ago
bug 94041 resulted in the background colors/images displaying in Quirks mode for
empty TDs with BGCOLOR/BACKGROUND attributes.

It seems appropriate to make the solution complete so that in Quirks mode
background colors or background images for table cells will show for empty cells
whether you code the BGCOLOR/BACKGROUND attributes on the cell or you code the
background-color, background-image via CSS. This will duplicate the behavior of
IE 5.5.
(Reporter)

Comment 1

16 years ago
Created attachment 55990 [details]
BGCOLOR/BACKGROUND example
(Reporter)

Comment 2

16 years ago
Created attachment 55991 [details]
background-color/background-image example

Comment 3

16 years ago
adding WRMB bugscape transition notations
Keywords: topembed
Priority: -- → P2
Summary: [quirks]Show Empty Table Cells STYLE background-color, and background-image → WRMB:[quirks]Show Empty Table Cells STYLE background-color, and background-image
Whiteboard: [bugscape: 94041]
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 4

16 years ago
Created attachment 56218 [details] [diff] [review]
change to quirk.css to always show backgrouds on empty cells in quirks mode
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Whiteboard: [bugscape: 94041] → [bugscape: 94041] PATCH

Comment 5

16 years ago
Comment on attachment 56218 [details] [diff] [review]
change to quirk.css to always show backgrouds on empty cells in quirks mode

r= alexsavulov
Attachment #56218 - Flags: review+

Comment 6

16 years ago
Chris, I think it would be good to get an additional 'r' from Hixie (the gray
eminence of *.css)
(Assignee)

Comment 7

16 years ago
Created attachment 56255 [details] [diff] [review]
revised patch

Comment 8

16 years ago
Comment on attachment 56255 [details] [diff] [review]
revised patch

sr=attinasi
Attachment #56255 - Flags: superreview+

Comment 9

16 years ago
what sites are affected by this?
(Reporter)

Comment 10

16 years ago
I do not know of any sites that are affected by this. It came out of documenting
the compatibility fix of bug 94041. It seemed inconsistent to tell developers
that bgcolor and background attributes would work on TD in quirks mode but
background-color and background-image CSS rules would not. If this is a big
issue, then mark it wontfix.
(Assignee)

Comment 11

16 years ago
-->trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: [bugscape: 94041] PATCH → [bugscape: 94041] PATCH CANDIDATE_094

Comment 12

16 years ago
Does this patch cause empty cells (for example on the tinderbox pages) to be
displayed ?
(Assignee)

Comment 13

16 years ago
The backgrounds will be displayed like IE does. Is this a problem?

Comment 14

16 years ago
Created attachment 56593 [details]
I didn't mean the background but the border
(Assignee)

Comment 15

16 years ago
Yes, empty-cells applies to borders too.

Comment 16

16 years ago
Hey karnaze, we now display tinderbox differently than IE (e.g.). Was this patch
too violent?
(Assignee)

Comment 17

16 years ago
Yea, I should have realized that a bug this easy has got to be wrong somehow. 
After to talking to attinasi, I need to teach the css parser to recognize a 
value like -moz-show-background-hide-borders on empty-cells.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

16 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 18

16 years ago
Created attachment 56768 [details] [diff] [review]
patch to add -moz-show-background value to empty-cells and make that the quirk default

Comment 19

16 years ago
Comment on attachment 56768 [details] [diff] [review]
patch to add -moz-show-background value to empty-cells and make that the quirk default

r=pierre

Updated

16 years ago
Attachment #56768 - Flags: review+

Comment 20

16 years ago
Comment on attachment 56768 [details] [diff] [review]
patch to add -moz-show-background value to empty-cells and make that the quirk default

sr=attinasi - nice non-violent patch
Attachment #56768 - Flags: superreview+
(Assignee)

Comment 21

16 years ago
The new patch is in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 22

16 years ago
*** Bug 108730 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 23

16 years ago
*** Bug 108896 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.