If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Survey site has invalid SSL certificate

RESOLVED WORKSFORME

Status

support.mozilla.org
General
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: douglas, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
Build ID: 20140608211457

Steps to reproduce:

1. Get selected for the Mozilla Firefox Support Site survey
2. Attempt to access over TLS/SSL (e.g. HTTPS Everywhere)


Actual results:

3. Get ssl_error_bad_cert_domain (sgizmo.com wildcard certificate)


Expected results:

3. Be able to use SSL to submit the form (qsurvey.mozilla.com certificate)
Kadir: Can you look into this and report to Survey Gizmo (assuming it's an issue on their end)? Or it is an issue with us using our custom domain?
Flags: needinfo?(a.topal)

Comment 2

2 years ago
this was brought up again by a user in the forum: https://support.mozilla.org/en-US/questions/1064626
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

2 years ago
See Also: → bug 1064066

Comment 3

2 years ago
it appears to happen for users with the https everywhere addon only
For me qsurvey.mozilla.com has it's own certificate now. So FIXED/WFM?

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Duplicate of this bug: 1151369
You need to log in before you can comment on or make changes to this bug.