[IMAP] Deleting messages on server deletes local copies as well

RESOLVED DUPLICATE of bug 157429

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 157429
3 years ago
3 years ago

People

(Reporter: mikeh, Unassigned)

Tracking

24 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

STR:
0. get "over quota" email from ISP
1. log into ISP's web mail, open inbox, delete all messages in inbox
2. switch back to Thunderbird, observe that inbox is now empty

I realize in retrospect that this is IMAP sync happening, but it would sure be nice to have a checkbox in T'bird that says "don't delete anything regardless of what happens on the upstream server".
Sounds like I'm not the first person to get bitten by this:
https://support.mozilla.org/en-US/questions/1007499
In IMAP, all is held at IMAP server any time, and state in IMAP client is sync'ed with server always .
"Locally held data for IMAP account" is merely a cached data for performance reason.
This is true even on Offline-Store file which is to hold "entire mail data of IMAP mails" in local file by auto-sync. "Data in Offline-Store file for IMAP" is never "local copy".
This is similar to "Web mail access via Browser" to mails which is held at server, which can not be viewed once mail data is deleted at server.
These are one of biggest difference in design/implementation of protocol named POP3 and IMAP, and one of biggest difference in design/implementation of POP3 account support and IMAP account support in mailers including Thunderbird.
(Note: In POP3, basic rule is "RETR then DLET, QUIT" at a small Mail Box in Post Office == transfer paper mail to home, as known by protocol name of "Post Office".)

So, if you need to keep data of IMAP mails locally even after mail is deleted at IMAP server, what you should do is pretty simple;
   How to keep data locally == Simply, explicitly download mail data to local file of you PC, as done in POP3l.
   (Note: This is absolutely same in "Web mail access via Browser".)
An objective of "Local Folders" account is this "keeping data of mails locally, even after mail is deleted at IMAP server".
    a) Choose "mail folder of Local Folders account" as "folder to archive mails" for the IMAP account in Thunderbird.
         Do archive operation at mail folder of this IMAP account.
    b) By message filter, move(or copy) all mails of IMAP account(or subset of mails) to mail folder of "Local Folders".

Feature for "don't sync with IMAP server any more. keep local cached data as-is" is already requested as "per account Work Offline mode".
However, "How to keep data locally" is obvious and pretty simple.
I don't think "per account Work Offline mode" like feature is mandatory, even though such feature is "nice to have".
Severity: normal → enhancement
FYI.
Bug 881966 is similar request to yours in different circumstance.
Bug 312619 is request of "per-account offline status".

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 157429
You need to log in before you can comment on or make changes to this bug.