Closed Bug 1078822 Opened 6 years ago Closed 6 years ago

[Settings] Software Home Button does not dismiss "Debugging via USB" menu

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified

People

(Reporter: smiko, Assigned: timdream)

References

()

Details

(Keywords: regression, Whiteboard: [FT:System-Platform][shb-enabled][2.2-Daily-Testing])

Attachments

(2 files)

Attached file devMenu.txt
Description:

Repro Steps:
1: Update a Flame to 20141006040204
2: Open Settings > Device Information > More Information > Enable Developer Menu
3: From the developer menu, enable the software home button > open the Debugging via USB menu
4: Press the software home button 

Actual: The menu remains, navigation takes place in the background.

Expected: The user is brought to the homescreen.

Flame 2.2 (319mb/fullflash)
Device: Flame 2.2
BuildID: Device: Flame 2.2
BuildID: 20141006040204
Gaia: 470826d13ae130a5c3d572d1029e595105485fb0
Gecko: e0d714f43edc
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Notes:
This issue does NOT occur using the normal home button.

Repro frequency: 100%

See attached: logcat

Video clip: http://youtu.be/-LRTeQH_tbc
This issue DOES repro on Flame 2.2 (319mb/Full flash/build 20141003040207)

Actual result: The menu remains, navigation takes place in the background.

Device: Flame 2.2 (319mb)
BuildID: 20141003040207
Gaia: d711d1e469eeeecf25a02b2407a542a598918b2c
Gecko: b85c260821ab
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
_____________________________________________________________________________

This issue does NOT repro on Flame 2.1 (319mb/Full flash)

Actual result: Homescreen is displayed.

Device: Flame 2.1
BuildID: 20141006000205
Gaia: 778ebac47554e1c4b7e9a952d73e850f58123914
Gecko: c4a4b04c617c
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Blocks: 1077579
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [shb-enabled][2.2-Daily-Testing]
[Blocking Requested - why for this release]:
Functional regression using SHB.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140905062812
Gaia: 04bfb7cab6a5485b650dac75cf99b8509ae148fc
Gecko: 6aa95efb9322
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140905063113
Gaia: 04bfb7cab6a5485b650dac75cf99b8509ae148fc
Gecko: 0bb6b880744e
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=6aa95efb9322&tochange=0bb6b880744e

Caused by Bug 1057898?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Caused by Bug 1057898 - Tim, can you take a look
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(timdream)
Yeah, probably a timing issue caused by that Gecko patch. The strange thing is, the hardware home button is blocked when that menu is shown.
Assignee: nobody → timdream
Status: NEW → ASSIGNED
Flags: needinfo?(timdream)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #5)
> Yeah, probably a timing issue caused by that Gecko patch. The strange thing
> is, the hardware home button is blocked when that menu is shown.

It turned out the hardware button is disabled when the software button is shown. Two buttons are indeed behave the same way.
Comment on attachment 8501603 [details] [review]
mozilla-b2g:master PR#24928

Without looking deep into Gecko, the fix for this bug is to prevent the software home button from getting focus. I think this is the acceptable fix at the moment, as this is a 2.2 blocker -- will clone another bug to investigate on Gecko side.
Attachment #8501603 - Flags: review?(alive)
Attachment #8501603 - Flags: review?(alive) → review+
Component: Gaia::Settings → Gaia::System
Whiteboard: [shb-enabled][2.2-Daily-Testing] → [FT:System-Platform][shb-enabled][2.2-Daily-Testing]
Target Milestone: --- → 2.1 S6 (10oct)
This issue is verified fixed on Flame 2.2

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141010040202
Gaia: 1036b544b7e102592bd9fab95cd9317329ac1293
Gecko: 50b689feab5f
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Pressing software home button on the Debugging via USB menu brings user back to the home screen.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This bug is not completely fixed -- I can still reproducible it by opening up the Language menu and hit soft home button.

I will try to find the underlining issue with bug 1079728.
Status: VERIFIED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: FIXED → INCOMPLETE
Ouch, I am sorry, I was on an old version which this patch was not included.
Status: RESOLVED → VERIFIED
Resolution: INCOMPLETE → FIXED
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.