If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent test_a11y_keyboard_word_suggestions.py TestA11yKeyboardWordSuggestions.test_a11y_keyboard_word_suggestions | JavascriptException: JavascriptException: TypeError: Argument 1 of Window.getComputedStyle is not an object

RESOLVED DUPLICATE of bug 1078156

Status

Firefox OS
Gaia::UI Tests
RESOLVED DUPLICATE of bug 1078156
3 years ago
3 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
https://treeherder.mozilla.org/ui/logviewer.html#?job_id=832758&repo=fx-team
builder 	b2g_macosx64 fx-team opt test gaia-ui-test
buildid 	20141006132417
builduid 	69889b74d4c949e59427f41e0651ec97
results 	warnings (1)
revision 	f4953072c20f
slave 	talos-mtnlion-r5-062
starttime 	Mon Oct 06 2014 14:45:08 GMT-0700 (Pacific Standard Time)



15:04:44 INFO - TEST-PASS | test_prefs.py TestPrefs.test_get_set_int_pref | took 18671ms
15:04:44 INFO - TEST-START | test_warm_launch.py TestWarmLaunch.test_warm_launch
15:05:04 INFO - TEST-PASS | test_warm_launch.py TestWarmLaunch.test_warm_launch | took 20186ms
15:05:04 INFO - TEST-START | test_a11y_ftu_desktopb2g.py TestFtuAccessibility.test_a11y_ftu
15:05:25 INFO - TEST-PASS | test_a11y_ftu_desktopb2g.py TestFtuAccessibility.test_a11y_ftu | took 21212ms
15:05:25 INFO - TEST-START | test_a11y_keyboard_word_suggestions.py TestA11yKeyboardWordSuggestions.test_a11y_keyboard_word_suggestions
15:05:25 ERROR - TEST-UNEXPECTED-ERROR | test_a11y_keyboard_word_suggestions.py TestA11yKeyboardWordSuggestions.test_a11y_keyboard_word_suggestions | JavascriptException: JavascriptException: TypeError: Argument 1 of Window.getComputedStyle is not an object.
15:05:25 INFO - stacktrace:
15:05:25 INFO - @app://system.gaiamobile.org/js/app_chrome.js, line 447
15:05:25 INFO - Traceback (most recent call last):
15:05:25 INFO - File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 249, in run
15:05:25 INFO - self.setUp()
15:05:25 INFO - File "/builds/slave/talos-slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/tests/accessibility/keyboard/test_a11y_keyboard_word_suggestions.py", line 13, in setUp
15:05:25 INFO - GaiaTestCase.setUp(self)
15:05:25 INFO - File "/builds/slave/talos-slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 720, in setUp
15:05:25 INFO - MarionetteTestCase.setUp(self)
15:05:25 INFO - File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 540, in setUp
15:05:25 INFO - CommonTestCase.setUp(self)
15:05:25 INFO - File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 390, in setUp
15:05:25 INFO - self.close_test_container()
15:05:25 INFO - File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 500, in close_test_container
15:05:25 INFO - }""", script_timeout=60000)
15:05:25 INFO - File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/marionette.py", line 1269, in execute_async_script
15:05:25 INFO - filename=os.path.basename(frame[0]))
15:05:25 INFO - File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/decorators.py", line 35, in _
15:05:25 INFO - return func(*args, **kwargs)
15:05:25 INFO - File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/marionette.py", line 638, in _send_message
15:05:25 INFO - self._handle_error(response)
15:05:25 INFO - File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/marionette.py", line 686, in _handle_error
15:05:25 INFO - raise errors.JavascriptException(message=message, status=status, stacktrace=stacktrace)
15:05:25 INFO - TEST-INFO took 209ms
15:05:25 INFO - TEST-START | test_a11y_phone_keypad.py TestAccessibilityPhoneKeypad.test_phone_keypad
15:05:51 INFO - TEST-PASS | test_a11y_phone_keypad.py TestAccessibilityPhoneKeypad.test_phone_keypad | took 25438ms
15:05:51 INFO - TEST-START | test_a11y_phone_select_toolbars.py TestAccessibilityPhoneSelectToolbars.test_phone_select_toolbars
15:06:11 INFO - TEST-PASS | test_a11y_phone_select_toolbars.py TestAccessibilityPhoneSelectToolbars.test_phone_select_toolbars | took 20389ms
Looks the same as Bug 1078156.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: Gaia::Keyboard → Gaia::UI Tests
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1078156
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 7

3 years ago
The manifest files that TBPL uses was changed by releng which caused this test to be enabled again.

We've since disabled it again.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.