[Window Mgmt] Confirmation screen for deleting installed app overlays over all other elements and notifications.

VERIFIED FIXED in 2.1 S8 (7Nov)

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: cinnes, Assigned: tedders1)

Tracking

({regression})

unspecified
2.1 S8 (7Nov)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-flame-test-run-3] [systemsfe], URL)

Attachments

(2 attachments, 1 obsolete attachment)

7.65 KB, text/plain
Details
46 bytes, text/x-github-pull-request
kgrandon
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
Created attachment 8500760 [details]
logcat.txt

Description:
When user tries to delete marketplace installed app from homescreen, the resulting window covers all proceeding page elements. Notifications, incoming call screens, long press power screen, and volume change meter do not appear when user interacts with phone. All elements of the app delete confirmation screen are usable and phone is not frozen. If user long presses power button and then cancels or deletes app the power off prompt screen will be accessible. 
   
Repro Steps:
1) Update a Flame device to BuildID: 20141006000205
2) Install any app from Marketplace
3) Return to home screen
4) Long press Marketplace installed app
5) Tap red "x" to bring up deletion menu
6) Have second device send sms or call device 
  
Actual:
No notification or call screen appears and app deleting screen remains.
  
Expected: 
Notification and calls should appear over deletion screen.
  
Environmental Variables:
Device: Flame 2.1 kk (319mb)(full flash)
BuildID: 20141006000205
Gaia: 778ebac47554e1c4b7e9a952d73e850f58123914
Gecko: c4a4b04c617c
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 3/3, 100%, 
See attached: Youtube video clip, logcat
Youtube video link: https://www.youtube.com/watch?v=qRXhLCMF3-Q
(Reporter)

Comment 1

4 years ago
Issue DOES occur on Flame 2.2 kk (319mb)(Full Flash) 
Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141006040204
Gaia: 470826d13ae130a5c3d572d1029e595105485fb0
Gecko: e0d714f43edc
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Actual Results: No notification or call screen appears and app deleting screen remains.

Issue does NOT occur on Flame 2.0 kk (319mb)(Full Flash)
Flame 2.0 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.0
BuildID: 20141006000202
Gaia: 092d2b7678774c8b0b06dca0e0a8119e9eafdec3
Gecko: 69ca61f7edf3
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Actual Results: Notification and calls should appear over deletion screen.

Notes: This bug was found outside of any test case but during the 2.1-3 test pass.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
This seems like the same issue as bug 1077609. Checking tomorrows nightly master to see if it is fixed before making a resolution decision
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
(Reporter)

Comment 3

4 years ago
App deletion confirmation screen also covers software home button completely. This still only applies to installed marketplace apps. 

Device: Flame 2.1 kk (319mb)(Full Flash)
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

When trying to delete an app from the marketplace the user sees a confirmation overlay before deleting the app, this app goes to the top of the stack and makes it so the user cannot go home, answer a call, power off the device, ect until they tap on cancel or delete. Nominating as a blocker
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regressionwindow-wanted
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140825072248
Gaia: b9cd16c8a4518ab6b02311e596a247977af56001
Gecko: 4b37cddaed77
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140825075947
Gaia: 169a465e71138b892799b8a8f188eaf7d1bf06d0
Gecko: c99f0f778f7a
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: 169a465e71138b892799b8a8f188eaf7d1bf06d0
Gecko: 4b37cddaed77

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: b9cd16c8a4518ab6b02311e596a247977af56001
Gecko: c99f0f778f7a

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/b9cd16c8a4518ab6b02311e596a247977af56001...169a465e71138b892799b8a8f188eaf7d1bf06d0

Caused by Bug 1042797.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Broken by Bug 1042797 ? Can you take a look Ted?
Blocks: 1042797
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(tclancy)

Updated

4 years ago
Whiteboard: [2.1-flame-test-run-3] → [2.1-flame-test-run-3] [systemsfe]
Known issue, broken functionality. definitely a blocker
Assignee: nobody → tclancy
blocking-b2g: 2.1? → 2.1+
Target Milestone: --- → 2.1 S7 (24Oct)
(Assignee)

Comment 8

4 years ago
Created attachment 8507839 [details] [review]
Bug-1078901-fix
Flags: needinfo?(tclancy)
Attachment #8507839 - Flags: review?(kgrandon)
Comment on attachment 8507839 [details] [review]
Bug-1078901-fix

Looking good, but I think the styles need some additional thought. Left some comments on github, please re-flag me when ready. Thanks!
Attachment #8507839 - Flags: review?(kgrandon)
(Assignee)

Comment 10

4 years ago
Hi Kevin. I responded to the comments on Github.
Flags: needinfo?(kgrandon)
Thanks Ted. I think we should just move the selectors into the system app and we should be good.
Flags: needinfo?(kgrandon)
(Assignee)

Comment 12

4 years ago
Hey Kevin. It turns out I can't add selectors to those existing CSS rules, because the existing rules affect the "bottom" property and I need to set the "margin-bottom" property.

But I've moved the new rules out of shared and into system.
(Assignee)

Updated

4 years ago
Attachment #8507839 - Flags: review?(kgrandon)
Comment on attachment 8507839 [details] [review]
Bug-1078901-fix

Looks good to me. Thanks.
Attachment #8507839 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/bb6f9d1b5e721b81a2fb4116ac2151492a7e75f0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
https://github.com/mozilla-b2g/gaia/commit/f46d56d812480bff7f3b35e8cacbedfa4d49edc5

This caused breakage on Gij. Ted - can you take a look?
Status: RESOLVED → REOPENED
Flags: needinfo?(tclancy)
Resolution: FIXED → ---
(Assignee)

Comment 16

4 years ago
Created attachment 8511572 [details] [review]
Bug-1078901-fix
Attachment #8507839 - Attachment is obsolete: true
Flags: needinfo?(tclancy)
Attachment #8511572 - Flags: review?(kgrandon)
(Assignee)

Comment 17

4 years ago
Hi Kevin,

Sorry about that. My previous patch caused a failure in apps/keyboard/test/marionette/uninstallation_test.js. At the time I submitted the patch, so many tests were already breaking, I didn't notice that I broke one additional test.

The problem was that one of the tests calls uninstall() while the on-screen keyboard is still visible, and the confirmation dialog appears underneath the keyboard.

I've added a line to shared/js/homescreens/confirm_dialog_helper.js to hide the on-screen keyboard before showing the confirmation dialog.

Successful gaia-try run is here: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=cabfbb21db2b
Target Milestone: 2.1 S7 (24Oct) → 2.1 S8 (7Nov)
Comment on attachment 8511572 [details] [review]
Bug-1078901-fix

Seems fine to me. Thanks!
Attachment #8511572 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/70b12c46492ef92197c68a6abe0e8478985df2fa

Please request Gaia v2.1 approval on this when you get a chance :)
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-b2g-v2.2: affected → fixed
Flags: needinfo?(tclancy)
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Comment 20

4 years ago
Comment on attachment 8511572 [details] [review]
Bug-1078901-fix

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #):
Bug 1042797.

[User impact] if declined:
If a user gets a phone call while installing an app, they can't answer the phone call. (Also, they can't see notifications.)

[Testing completed]:
TBPL run here: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=cabfbb21db2b

Also, I manually test receiving a text message while installing an app, and it worked.

[Risk to taking this patch] (and alternatives if risky):
This has been on master for a week now, and no problems have been noticed.

[String changes made]:
None
Flags: needinfo?(tclancy)
Attachment #8511572 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8511572 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
When trying to verify this a few issues popped up, if I tap an SMS notification while on app deletion screen the Messages app opens beneath the confirmation screen and cannot be seen by user until they cancel or confirm deletion of app. Because of this, further sms notifications are not visible to user. 

In addition, home button does not return user to homescreen while on app deletion page.

Is this expected behavior?
Flags: needinfo?(tclancy)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 23

4 years ago
Verified the issue is fixed on 2.2 and 2.1
When "Delete" confirmation screen appears, it's active user receives notifications, incoming call screen appears, volume level is changing, and long pressed "home" button works

Device: Flame 2.2 Master KK
BuildID: 20141105160209
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: 2114ef80f6ae
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1 KK
BuildID: 20141106001204
Gaia: 9658b93b412bdcc0f953d668e8c8e68318c99fb8
Gecko: 76880403db44
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Comment 24

4 years ago
> Is this expected behavior?

Probably not.
Flags: needinfo?(tclancy)
You need to log in before you can comment on or make changes to this bug.