[System] Bluetooth confirmation buttons cutoff by swb

VERIFIED FIXED in 2.1 S6 (10oct)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: rnicoletti, Assigned: apastor)

Tracking

unspecified
2.1 S6 (10oct)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

When sharing a video via bluetooth while bluetooth is not yet enabled, the buttons on the 'enable bluetooth' confirmation dialog are partially hidden by the swb.

STR:

1) Using latest master branch, pply the patch from bug 1055198
2) Install video app

On devices with a hardware home button:
3) 'adb shell setprop ro.moz.has_home_button 0'
4) stop and start b2g

5) Disable bluetooth if it is enabled
6) Open video app, select video using 'select' button
7) Share video with 'share' button
8) Choose 'bluetooth transfer'
Blocks: 1055198
[Blocking Requested - why for this release]: Broken feature.
Blocks: 1077579
blocking-b2g: --- → 2.1?
Note: this seems to be a fullscreen layout specific feature.
Alberto, you got the cycles to check this out?
Flags: needinfo?(apastor)
Broken feature
blocking-b2g: 2.1? → 2.1+
Assignee: nobody → apastor
Flags: needinfo?(apastor)
I'm not sure why this bug is 2.1+, when the STR include applying a patch which haven't landed (and is not 2.1+). Gregor, could you please clarify? Thanks!
Flags: needinfo?(anygregor)
Whiteboard: [systemsfe]
(In reply to Alberto Pastor [:albertopq] from comment #5)
> I'm not sure why this bug is 2.1+, when the STR include applying a patch
> which haven't landed (and is not 2.1+). Gregor, could you please clarify?
> Thanks!

Oh you are right. No need to block 2.1.
blocking-b2g: 2.1+ → backlog
Flags: needinfo?(anygregor)
[Blocking Requested - why for this release]: After checking, it seems that is a general bug (not only with the video patch) when interacting SHB and inline activities in fullscreen_layout apps, so nominating again. Should be a quick css fix
blocking-b2g: backlog → 2.1?
Comment on attachment 8502366 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24984

Nice! Definitely useful for 2.1.
(Small comment on github.)
Attachment #8502366 - Flags: review?(etienne) → review+
Target Milestone: --- → 2.1 S6 (10oct)
blocker because it affects how media apps appear.
blocking-b2g: 2.1? → 2.1+
master: https://github.com/mozilla-b2g/gaia/commit/60bdd5880d1e69919c6c7947108f454a778f8f7c
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8502366 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24984

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): SHB feature
[User impact] if declined: SHB overlays inline activities on fullscreen apps
[Testing completed]: Added integration tests
[Risk to taking this patch] (and alternatives if risky): Low risk. Css only and well test covered
[String changes made]: -
Attachment #8502366 - Flags: approval-gaia-v2.1?(fabrice)
Comment on attachment 8502366 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24984

low risk css change, approving on 2.1.
Attachment #8502366 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Unable to verify this bug because it requires a patch to be applied from a bug that has not yet been resolved.
QA Whiteboard: [QAnalyst-verify-][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-verify-][QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-testsuite+
Issue verified fixed on Flame 2.2 

Actual Results: Bluetooth confirmation buttons are not cut off by Software Home Button. The buttons appear above SHB when enabled, and anchored to bottom of screen when SHB is disabled.

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141110040206
Gaia: 5cce8717451dde968930fc0c51efbb259e454fce
Gecko: d380166816dd
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Unable to check Flame 2.1 as patch in STR is for Master. Leaving verifyme until patch is made commit and uplifted to 2.1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Posted video VIDEO0051.mp4
This issue has been successfully verified on Flame 2.1:
Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141119001205
Version         34.0
Device-Name     flame
FW-Release      4.4.2
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.