[Browser][Twitter] Black screen occurs when swiping on twitter log in page

RESOLVED WONTFIX

Status

()

Core
Graphics
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: cnelson, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(platform-rel ?, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe][2.1-flame-test-run-3][shb-enabled][platform-rel-Twitter], URL)

(Reporter)

Description

4 years ago
When scrolling to the right or left on the twitter page after reaching the page through the browser, the page will become a blank black screen.  Note that the twitter image will return if the user continues to swipe at the screen, and is easier to reproduce when loading into the page for the first time.  Refer to video attached for a visual aid.

Prerequisites: Turn on software home button, and don't plug device into laptop.

Repro Steps:
1) Update a Flame device to BuildID: 20141006000205
2) Open up the browser or use the rocket bar.
3) Search for www.twitter.com.
4) Once the page loads, swipe to the left or right.
5. Notice the screen may become black and or blank.
  
Actual:
Swiping to the left or right of the twitter login page will sometimes cause a black screen.
  
Expected: 
The screen will not become black nor blank, and will instead use edge gesture like all other pages/apps.
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20141006000205
Gaia: 778ebac47554e1c4b7e9a952d73e850f58123914
Gecko: c4a4b04c617c
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 80%
Link to failed test case: https://moztrap.mozilla.org/manage/case/2536/
See attached: video clip

https://www.youtube.com/watch?v=m18v4f2wroY
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
Issue does occur on 2.2 flame kk (319mb) (full flash) 

Swiping to the left or right of the twitter login page will sometimes cause a black screen.

Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141006040204
Gaia: 470826d13ae130a5c3d572d1029e595105485fb0
Gecko: e0d714f43edc
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Issue doesn't occur on 2.0 flame kk (319) (full flash)

The screen will not become black nor blank, and will instead use edge gesture like all other pages/apps.

Flame 2.0 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.0
BuildID: 20141006000202
Gaia: 092d2b7678774c8b0b06dca0e0a8119e9eafdec3
Gecko: 69ca61f7edf3
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Not blocking on this issue because the user can recover from the black screen by simply swiping the opposite direction that they originally swiped.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Is this a graphics issue?
Component: Gaia::System::Browser Chrome → Graphics
Product: Firefox OS → Core
Blocks: 1073549
blocking-b2g: --- → backlog

Comment 4

4 years ago
add tracking flag for backlog.
tracking-b2g: --- → +
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---

Updated

3 years ago
tracking-b2g: + → ---
Whiteboard: [systemsfe][2.1-flame-test-run-3][shb-enabled] → [systemsfe][2.1-flame-test-run-3][shb-enabled][platform-rel-Twitter]

Updated

2 years ago
platform-rel: --- → ?
Flame device regression.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.