Firefox fails to play videos on Windows if no sound-card is available

VERIFIED FIXED in Firefox 35

Status

()

Core
Audio/Video
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: cosmin, Assigned: jwwang)

Tracking

unspecified
mozilla35
All
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox35+ verified)

Details

(Whiteboard: [mozmill])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8500936 [details]
Screenshot from 2014-10-07 12:46:22.png

With bug 1051658 landed, if Firefox fails to decode the audio stream the video won't be played at all. 
This is the case if you don't have a sound-card available.

The first failing build is ftp://ftp.mozilla.org/pub/firefox/tinderbox-builds/mozilla-inbound-win32/1412345616/ 

To be able to reproduce this:
1 Open a Windows machine with no sound-card (you can disable it if you're using a VM box)
1 Install the latest nightly
2 Open: http://mozqa.com/data/firefox/video/sample-video-60s.ogv

Expected: Video will play without sound

Actual result: Video won't play, error: "Video can't be played because the file is corrupt."
               And on browsers console: "Media resource http://www.mozqa.com/data/firefox/video/sample-video-60s.ogv could not be decoded."
(Reporter)

Updated

4 years ago
No longer blocks: 1005847
(Reporter)

Updated

4 years ago
Blocks: 1005847
(Assignee)

Comment 1

4 years ago
(In reply to Cosmin Malutan from comment #0)
> Expected: Video will play without sound

Is this behavior common to other browsers? If so, we should make no exception for Firefox. How about playing an audio-only file without sound card installed? Does it still play without sound output or fail to play at all?
(Reporter)

Comment 2

4 years ago
No, an audio only file won't play neither. Regarding other browsers they all play the video only if you don't have a sound-card installed and they won't bailout the video too.
[Tracking Requested - why for this release]:
status-firefox35: --- → affected
tracking-firefox35: --- → ?
Whiteboard: [mozmill]
Btw. does this only happen on Windows or also on other platforms?
Flags: needinfo?(cosmin.malutan)
(Reporter)

Comment 5

4 years ago
Only on windows, I've checked exactly the same steps on Linux, but there it work just fine.
Flags: needinfo?(cosmin.malutan)
(Assignee)

Comment 6

4 years ago
Created attachment 8501405 [details] [diff] [review]
1079174_allow_video_playback_when_audiostream_fail.patch

It looks like cubeb_wasapi will fail to init a stream when sound card not present. Per comment 0, the user expects to play video in spite of sound error. We should ignore the AudioSink error when there is still video to play.

Try: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=c7ee6f27bfac
Looks fine.
Assignee: nobody → jwwang
Status: NEW → ASSIGNED
Attachment #8501405 - Flags: review?(kinetik)
Attachment #8501405 - Flags: review?(kinetik) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
tracking-firefox35: ? → +
https://hg.mozilla.org/mozilla-central/rev/1d9f0405f64d
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox35: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
(Reporter)

Comment 9

4 years ago
This has been fixed, it passes the test too.
Thanks.
Status: RESOLVED → VERIFIED
status-firefox35: fixed → verified
You need to log in before you can comment on or make changes to this bug.