If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

graph server alerts seem way too quiet

RESOLVED FIXED

Status

Webtools Graveyard
Graph Server
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: jmaher, Assigned: catlee)

Tracking

Details

(Reporter)

Description

3 years ago
I have seen no regressions from graph server in the last week, but on the flip side Kyle's alerting system has continued to generate alerts.  While we are probably experiencing a break in crazy wild patches, I suspect the analyze_talos.py script is erroring out or failing in some way.

For example look at svg opacity, win8:
http://graphs.mozilla.org/graph.html#tests=%5B%5B225,64,33%5D,%5B225,63,33%5D,%5B225,131,33%5D,%5B225,131,31%5D,%5B225,131,25%5D,%5B225,131,37%5D%5D&sel=none&displayrange=7&datatype=running

on oct 3, we had a bump in the overall number- this was not reported at all on dev.tree-management.

I recall back in May :catlee mentioned having to kick the anaylze_talos.py process due to it hanging or some other error.  We need to look into this now.
(Assignee)

Comment 1

3 years ago
Looks like it's erroring out trying to fetch some revision from pushlog.
Assignee: nobody → catlee
(Assignee)

Comment 2

3 years ago
Some data was submitted with revision 0000000NULL, so the regression detector was trying to find when that revision was pushed via:

http://hg.mozilla.org/integration/mozilla-inbound/json-pushes?full=1&changeset=00000000NULL

I've adjusted the script to ignore this kind of failure. Prepare for a flood of alerts!
(Reporter)

Comment 3

3 years ago
alerts are coming out now.  I am not sure why we were sending 000000NULL as the revision, this isn't talos related, but I suspect it is relate to a bug in the browser, maybe related to e10s changes.

shall we close this bug?
(Assignee)

Comment 4

3 years ago
Sure - landed my fixes here - http://hg.mozilla.org/graphs/rev/d6cace45c142
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.