[Messages] Flip Settings.supportEmailRecipient to true when the functionality is ready

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::SMS
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: julienw, Assigned: salva)

Tracking

unspecified
2.2 S4 (23jan)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, tracking-b2g:backlog, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
In bug 840515 and its dependencies, we implement the functionality of "send MMS by email", but it's currently pref-ed off until it's finished.

In this bug, we want to simply flip this setting to true. We may need to update unit tests that assume the setting is false by default.
(Reporter)

Updated

4 years ago
Blocks: 1079257
blocking-b2g: --- → backlog
tracking-b2g: --- → +
feature-b2g:2.2+ for it's to pref on the feature together with bug 997547
feature-b2g: --- → 2.2+
tracking-b2g: + → ---
setting target milestone to align with bug 997547, which I see has r+'d
Target Milestone: --- → 2.2 S3 (9jan)
Assignee: nobody → salva
Created attachment 8546502 [details] [review]
Set flag for enabling MMS to e-mails to true and adding integration tests

Hi Oleg.

This bug includes integration tests for the new switching to MMS cases and a new suite case gathering the stuff about showing the conversion banner.

Do you mind to review the patch?
Attachment #8546502 - Flags: review?(azasypkin)
Hey Salva, looks and works great so far! I think only bug 1105646 still can annoy user, but it's quite minor.

Thanks for the tests. I've added just a few comments at GitHub - in short I'd like that we verify one more simple but important use case in both of your tests.

Keeping review flag for now.

Updated

3 years ago
Status: NEW → ASSIGNED
Oleg, I addressed the problems we've detected and finished the tests. Could you take a look? Let me know for any problem.
Comment on attachment 8546502 [details] [review]
Set flag for enabling MMS to e-mails to true and adding integration tests

(In reply to Salvador de la Puente González [:salva] from comment #5)
> Oleg, I addressed the problems we've detected and finished the tests. Could
> you take a look? Let me know for any problem.

Okay, perfect now! Just update PR with the last minor nits we discussed offline and wait for green Treeherder (please re-trigger Gij 2 job several times, 5 or more, to be sure we won't have intermittent failures).

Thanks a lot!
Attachment #8546502 - Flags: review?(azasypkin) → review+
master: 3b8b86f83fa489b6c3ddf65c38e75539c79985d9
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Seems that Treeherder show different errors in unrelated integration tests.
Comment on attachment 8546502 [details] [review]
Set flag for enabling MMS to e-mails to true and adding integration tests

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: big; all the functionality of bug 840515 has landed but it's not enabled yet. This bug enables the functionality and add Marionette tests checking the UI of Messages is behaving as expected.
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8546502 - Flags: approval-gaia-v2.2?
We have to request the approval because for some strange reason this bug did
not land on the v2.2 branch.
It seems that the branching left it out for some unknown reason.
status-b2g-v2.2: --- → affected

Updated

3 years ago
Attachment #8546502 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(In reply to Maria Angeles Oteo (:oteo) from comment #10)
> We have to request the approval because for some strange reason this bug did
> not land on the v2.2 branch.
> It seems that the branching left it out for some unknown reason.

It landed too late for the branching. No conspiracy theories needed ;)

v2.2: https://github.com/mozilla-b2g/gaia/commit/d82524d8e7092afb5dcb587f78e6f13653c6715b
status-b2g-v2.2: affected → fixed
status-b2g-master: --- → fixed
Target Milestone: 2.2 S3 (9jan) → 2.2 S4 (23jan)
QA Contact: lolimartinezcr
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.