Marionette should use unique temp dir for each session

RESOLVED WONTFIX

Status

Testing
Marionette
RESOLVED WONTFIX
3 years ago
10 months ago

People

(Reporter: lightsofapollo, Unassigned)

Tracking

({ateam-marionette-runner})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Currently marionette is using the same temp dirs for all operations. This means if you run tests in parallel its pretty easy to hit IO issues (and other weird stuff) simply buy running for long enough.

Some logs:

https://gist.github.com/lightsofapollo/f722f0663977b522aad9
https://gist.github.com/lightsofapollo/9388492f6c7c4d960fa2
https://gist.github.com/lightsofapollo/f0f51d50bb9b6d8a764a
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1079066
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1078990
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1078988
Keywords: ateam-marionette-runner
B2G related so closing.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.