Suggest updating ADB Helper if summonRoot is missing

RESOLVED FIXED in Firefox 37

Status

RESOLVED FIXED
4 years ago
4 months ago

People

(Reporter: jryans, Assigned: anirudhgp, Mentored)

Tracking

unspecified
Firefox 37

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=js])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Runtime details will says root is "unknown" if you don't have a new enough to ADB Helper to check it.

We should suggest updating the add-on to be more clear about the issue.
(Reporter)

Updated

4 years ago
Mentor: jryans
Whiteboard: [good first bug][lang=js]

Comment 1

4 years ago
Isn't the addon supposed to be auto-updated?
(Reporter)

Comment 2

4 years ago
(In reply to Paul Rouget [:paul] (slow to respond. Ping me on IRC) from comment #1)
> Isn't the addon supposed to be auto-updated?

Yes, but people can disable updates for all add-ons or specific add-ons.

:mdas, what was your situation?  Did you have to do a manual add-on update because you had disabled auto updates, or was something else going on?
Flags: needinfo?(mdas)
It didn't auto-update and I didn't really look into it much (maybe a pref was turned off?), I just removed it and installed the new one.
Flags: needinfo?(mdas)
(Reporter)

Comment 4

4 years ago
Okay, so we can't know for sure.  Regardless, there is no harm is saying something more helpful than "unknown".
(Assignee)

Comment 5

4 years ago
Hey I'd like to work on this bug. How do i begin??
(Reporter)

Comment 6

4 years ago
In WebIDE's Runtime Info panel[1], there is a string we show if the user does not have a version of ADB Helper that supports the right methods.

At the very least, we should extend that string to suggest that the user check that they have 0.4.0 or later of the add-on.  We could also go a bit further and inspect the add-on metadata to see what version they do have to present a more specific message.

[1]: http://dxr.mozilla.org/mozilla-central/source/browser/devtools/webide/content/runtimedetails.js#102
[2]: http://dxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/devtools/webide.properties#65
(Assignee)

Comment 7

4 years ago
Ok so instead of unknown, we can make it such that it checks what version of the add-on is currently present on the user's system and displays an appropriate message.  Correct?
(Reporter)

Comment 8

4 years ago
Yes, that sounds right.  The simplest version would be to just change the string to state that 0.4.0 or greater is needed.

Comment 9

4 years ago
Hi! I'm interested to fix one bug, but I'm new no bugzilla. I want to work in this bug and try to fix it until 30th october. Could someone mentor me?
(Reporter)

Comment 10

4 years ago
Yussif, you are welcome to give it a try.

To get started with our code base, see the hacking[1] page.

I believe the problem is well-defined in previous comments, but feel free to flag me as "needinfo" below if you have further questions.

[1]: https://wiki.mozilla.org/DevTools/Hacking
(Assignee)

Comment 11

4 years ago
(In reply to J. Ryan Stinnett [:jryans] from comment #8)
> Yes, that sounds right.  The simplest version would be to just change the
> string to state that 0.4.0 or greater is needed.

So we change "unknown" to "requires version 0.4.0 or greater" ?
(Reporter)

Comment 12

4 years ago
(In reply to anirudh.gp from comment #11)
> (In reply to J. Ryan Stinnett [:jryans] from comment #8)
> > Yes, that sounds right.  The simplest version would be to just change the
> > string to state that 0.4.0 or greater is needed.
> 
> So we change "unknown" to "requires version 0.4.0 or greater" ?

Yes, something like that.  Perhaps "unknown (requires ADB Helper 0.4.0 or later)".
(Assignee)

Comment 13

4 years ago
Thanks :) I'll get on it as soon as possible.
(Assignee)

Comment 14

4 years ago
Can i still work on this bug?
(Assignee)

Comment 15

4 years ago
Created attachment 8539227 [details] [diff] [review]
bug-1079336-fix.patch
Attachment #8539227 - Flags: review?(jryans)
(Reporter)

Comment 16

4 years ago
Comment on attachment 8539227 [details] [diff] [review]
bug-1079336-fix.patch

Review of attachment 8539227 [details] [diff] [review]:
-----------------------------------------------------------------

Cool, this seems like the right idea.  I've noted something to fix below.

::: browser/locales/en-US/chrome/browser/devtools/webide.properties
@@ +64,5 @@
>  addons_status_installing=installing
>  
>  runtimedetails_checkno=no
>  runtimedetails_checkyes=yes
> +runtimedetails_checkunkown=unknown (requires ADB Helper 0.4.0 or later)

When we change the string value of an existing string, we need to modify the string ID in some way[1].

Sometimes we do this by adding a number to the end of the ID.  In this case, it looks like "unkown" at the end of the ID is a misspelling of "unknown", so you can take care of this by fixing the misspelling (and also updating the page where this string ID is used).

[1]: https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_content_best_practices#Updating_Entity_Names
Attachment #8539227 - Flags: review?(jryans)
(Assignee)

Comment 17

4 years ago
Created attachment 8539674 [details] [diff] [review]
bug-1079336-fix-v2.patch
Attachment #8539227 - Attachment is obsolete: true
Attachment #8539674 - Flags: review?(jryans)
(Reporter)

Updated

4 years ago
Assignee: nobody → anirudh.gp
(Reporter)

Comment 18

4 years ago
Comment on attachment 8539674 [details] [diff] [review]
bug-1079336-fix-v2.patch

Review of attachment 8539674 [details] [diff] [review]:
-----------------------------------------------------------------

Great, this looks good to me!

Pushed to try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b483f1579be4

Add checkin-needed assuming Try looks good.
Attachment #8539674 - Flags: review?(jryans) → review+
(Reporter)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 19

4 years ago
Great. Thanks!
https://hg.mozilla.org/integration/fx-team/rev/1646139d1efa
Keywords: checkin-needed
Whiteboard: [good first bug][lang=js] → [good first bug][lang=js][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/1646139d1efa
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [good first bug][lang=js][fixed-in-fx-team] → [good first bug][lang=js]
Target Milestone: --- → Firefox 37

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.