[Utility Tray] Update-related strings appear in bigger font

VERIFIED FIXED

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: mancas)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8501210 [details]
Update_Related_Strings_Bigger_Font_Than_Rest

Description:
On the Utility Tray, strings regarding update appear in bigger font size than the rest. 

Repro Steps:
1) Update a Flame device to BuildID: 20141006040204.
2) Go to Settings > Device information > Check Now (under Software Information).
3) Observe "1 update available" notification. Download the available update file, and observe the string on the notification tray during the download process.

Actual:
The font size is bigger than the rest.

Expected:
The font size is same as the other notification strings.

Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141006040204
Gaia: 470826d13ae130a5c3d572d1029e595105485fb0
Gecko: e0d714f43edc
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Repro frequency: 100%
See attached: screenshot
(Reporter)

Comment 1

3 years ago
Created attachment 8501213 [details]
2.1vs2.2.png

This issue does NOT reproduce on Flame 2.1:

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141007000203
Gaia: 7f738edf66b9298bceef8a4981d05d04fd04e540
Gecko: b9d04c58580a
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Update-related notifications appear in the same font size as other notifications. See attached screenshot.
(Reporter)

Comment 2

3 years ago
This bug fails verification of Bug 1067356.
Blocks: 1038723
QA Whiteboard: [QAnalyst-Triage?]
No longer depends on: 1038723
Flags: needinfo?(ktucker)
Nominating this 2.2? since this will cause multiple strings to appear truncated. 

Removing the word the word regression since this is a result of a fix that was uplifted to 2.2 that did not resolve the issue.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regression
(Assignee)

Updated

3 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 4

3 years ago
Created attachment 8503004 [details] [review]
Font size reduced
Attachment #8503004 - Flags: review?(timdream)
(Assignee)

Comment 5

3 years ago
Created attachment 8503005 [details]
update-notification.png
Attachment #8503005 - Flags: ui-review?(jelee)
Comment on attachment 8503004 [details] [review]
Font size reduced

I am confused. I thought we already decoupled the lock screen style and the utility tray style? Greg, could you comment?

Guillaume, I realized you reviewed bug 1067356. Please note that only an module owner/peer can set r? to non-owner/peer. Although it's not documented in the bug, I supposed you have someone in [1] in the loop when working on that bug (maybe Kevin?)

[1] https://wiki.mozilla.org/Modules/FirefoxOS#System

That said, I think you should be able to review this patch -- set the review flag to you.
Attachment #8503004 - Flags: review?(timdream)
Attachment #8503004 - Flags: review?(gmarty)
Attachment #8503004 - Flags: feedback?(gweng)
Comment on attachment 8503004 [details] [review]
Font size reduced

Yes, please fix 'system/style/fake-notification.css' if you want to fix the utility tray only. And looks that I missed to decouple this style at 'apps/system/lockscreen/style/lockscreen-fake-notification.css', so I would submit another to prevent more sharing styles like this.
Attachment #8503004 - Flags: feedback?(gweng)

Comment 8

3 years ago
Comment on attachment 8503005 [details]
update-notification.png

Hi Eric,
I believe you're the visual designer for utility tray? Please take a look at this, thanks :)
Attachment #8503005 - Flags: ui-review?(jelee) → ui-review?(epang)
Comment on attachment 8503004 [details] [review]
Font size reduced

Looks good to me but as you said you'll want to get a r+ from a peer/owner, so pinging Etienne.
Attachment #8503004 - Flags: review?(gmarty)
Attachment #8503004 - Flags: review?(etienne)
Attachment #8503004 - Flags: review+
Comment on attachment 8503005 [details]
update-notification.png

Looks good, thanks for updating!
Attachment #8503005 - Flags: ui-review?(epang) → ui-review+
Comment on attachment 8503004 [details] [review]
Font size reduced

forwarding to Greg (since it's lockscreen) but the patch probably needs a rebase.
Attachment #8503004 - Flags: review?(etienne) → review?(gweng)
Comment on attachment 8503004 [details] [review]
Font size reduced

Please note that I've left my opinion at Comment 7: This is a modification only about UtilityTray, and *not* related with LockScreen, unless our bug is not completed. So please don't modify LockScreen styling file to affect utility notifications, since we had decoupled them. This patch works only because I missed this part, and it got plumbed at Bug 1081808.
Attachment #8503004 - Flags: review?(gweng)
(Assignee)

Comment 13

3 years ago
Fixed by bug 1081808
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Chris, can you please verify that this was fixed?
Flags: needinfo?(ckreinbring)
Keywords: verifyme
Fix verified on Flame 2.2.  I used yesterday's build to get the update notification.
Actual result:  The update available notification's text size is no larger or smaller than other notifications.

BuildID: 20141014001201
Gaia: 7e2e65a9668123b54c8cce5dacfdba6f4bd4672b
Gecko: 2325da834971
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Platform Version: 34.0
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: affected → verified
Flags: needinfo?(ckreinbring) → needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.