[Settings] USB storage set to MTP is not found by Linux PC's

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: RJ, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-flame-test-run-3], URL)

Attachments

(1 attachment)

579 bytes, text/plain
Details
(Reporter)

Description

4 years ago
Created attachment 8501238 [details]
Log cat

Description:
When the USB storage is set to MTP Linux based OS's do not detect the device.


Repro Steps:
1) Update a Flame to 20141006000205
2) Set USB to MPT
3) attach flame to Linux PC
4) Turn on USB storage 


Actual:
Flame is not detected 


Expected:
Flame is detected 

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141007000203
Gaia: 7f738edf66b9298bceef8a4981d05d04fd04e540
Gecko: b9d04c58580a
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency:100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/14298/
See attached:logcat,video clip: https://www.youtube.com/watch?v=aLZD0bWellE&list=UUlBL08Rzw8WLqi9VvigAvBw
(Reporter)

Comment 1

4 years ago
issue does occur on Flame 2.2 KitKat Base (319mb)(Full Flash)
MTP protocol is not detected by Linux based OS

Flame 2.2 KitKat Base (319mb)(Full Flash)
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141007040205
Gaia: 83de447d9ae9a59459d7a445f9348a254c661850
Gecko: 9ee9e193fc48
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Issue does not occur on Flame 2.0 KitKat Base (319mb)(Full Flash)
MTP was not implemented on 2.0

Flame 2.0 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.0
Build ID: 20141006000202
Gaia: 092d2b7678774c8b0b06dca0e0a8119e9eafdec3
Gecko: 69ca61f7edf3
Version: 32.0 (2.0)
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
After talking to the reporter, it seems as though MTP worked as expected when using windows. Not sure if linux is compatible with MTP or if some settings need to be changed for it to work on linux. NI Settings app owner to see if we can get some more info on this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(gchang)
Hi Alison,
Can you provide more info on this?
Flags: needinfo?(gchang) → needinfo?(ashiue)

Comment 4

4 years ago
MTP is supported in Windows XP if Windows Media Player 10 or later versions are installed. Windows Vista and later have MTP support built in.

From wiki, it seems Ubuntu 12.10 and higher has MTP support, while a workaround is available for older versions. Please refer: https://wiki.archlinux.org/index.php/MTP

If you are using Ubuntu 12.04, maybe you could refer the following article.
http://robert.penz.name/658/howto-access-mtp-devices-via-usb-on-ubuntu-12-04/
Flags: needinfo?(ashiue)

Comment 5

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.