If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Swarms repo isn't synced with getfirebug.com

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: sebo, Assigned: cturra)

Tracking

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1460] )

(Reporter)

Description

3 years ago
The GitHub repository at https://github.com/firebug/swarms needs to be synchronized with https://getfirebug.com/swarms/.

I added it as external resource to the getfirebug.com SVN repository at http://svn.mozilla.org/projects/getfirebug.com/tags/production/swarms as external resource, though that didn't fix the synchronization, unfortunately.

Sebastian

Updated

3 years ago
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1459] → [kanban:https://kanbanize.com/ctrl_board/4/1459] [kanban:https://kanbanize.com/ctrl_board/4/1460]
(Reporter)

Comment 1

3 years ago
What are these whiteboard entries for, kanban?

Sebastian
(Assignee)

Comment 2

3 years ago
the external change cause svn to require a conflict resolution (stdout at the end of my comment).

out of curiosity, why are you moving the swarms into an svn external? it's already being actively updated (git co master; git pull) as part of the update cron every 15 minutes. we should use one or the other, not both. thoughts?


[root@genericadm.private.phx1 getfirebug]# svn up
Updating '.':
Conflict for property 'svn:externals' discovered on '/data/genericrhel6/src/getfirebug.com/getfirebug'.
Select: (p) postpone, (df) diff-full, (e) edit,
        (s) show all options: df
--- /data/genericrhel6/src/getfirebug.com/svn-B8pqTo	Thu Oct 16 13:18:19 2014
+++ /tmp/svn-BubxBo	Thu Oct 16 13:18:19 2014
@@ -1 +1,5 @@
-https://fbug.googlecode.com/svn/extensions/swarm/branches/swarm1.7/swarms swarms
+<<<<<<< (modified)
+
+=======
+swarms https://github.com/firebug/swarms/
+>>>>>>> (latest)
Select: (p) postpone, (df) diff-full, (e) edit, (r) resolved,
        (s) show all options: e
Select: (p) postpone, (df) diff-full, (e) edit, (r) resolved,
        (s) show all options: r
Assignee: server-ops-webops → cturra
Flags: needinfo?(sebastianzartner)
(Reporter)

Comment 3

3 years ago
> out of curiosity, why are you moving the swarms into an svn external?

Three reasons:
1. It was already an svn external before it was moved to GitHub.
2. The rest of the getfirebug.com website is maintained within the Subversion repo.
3. The manual and automated tests are also svn externals coming from GitHub.

Sebastian
Flags: needinfo?(sebastianzartner)
(Assignee)

Comment 4

3 years ago
gotcha. thanks for the clarication. if you want to go this route, i will remove the swarms update code from the update script.

with regards to the svn externals here, i only see one:

  swarms https://github.com/firebug/swarms/


is that expected?


finally, when i do an `svn up` in that directory, i am seeing the following error:

[root@genericadm.private.phx1 getfirebug]# svn up
Updating '.':

Fetching external item into 'swarms':
svn: warning: W155010: The node '/data/genericrhel6/src/getfirebug.com/getfirebug/swarms' was not found.


i can confirm the swarms directory is present.

 [root@genericadm.private.phx1 getfirebug]# ls -ld /data/genericrhel6/src/getfirebug.com/getfirebug/swarms
 drwxr-xr-x 37 root root 4096 Oct  6 01:45 /data/genericrhel6/src/getfirebug.com/getfirebug/swarms
Flags: needinfo?(sebastianzartner)
(Reporter)

Comment 5

3 years ago
> with regards to the svn externals here, i only see one:
> 
>  swarms https://github.com/firebug/swarms/

The main folder just has this external, yes. The other externals are applied to the 'tests' subfolder.

> Fetching external item into 'swarms':
> svn: warning: W155010: The node '/data/genericrhel6/src/getfirebug.com/getfirebug/swarms' was not found.

Strange. It works fine on my Windows machine. I.e. I see a 'branches' and a 'trunk' folder under 'swarms'. Unfortunately I'm not a Subversion expert to tell you how to fix that.
The only two answers to this I found on the net so far are 'it's a symlink, svn commands need a real path'[1] - which is obviously not the case here - and 'not in Subversion, just ignore it'[2].

The only differences between this external and the 'tests' externals I saw right now are that for the Swarms external the repo URL is written after the alias while in the 'tests' externals the URLs come before the aliases:

I.e.

swarms https://github.com/firebug/swarms/

vs.

https://github.com/firebug/test-result-viewer/trunk result-viewer
https://github.com/firebug/manual-tests/trunk manual
https://github.com/firebug/firebug/trunk/tests/content head
https://github.com/firebug/firebug/branches/firebug1.9/tests/content 1.9
https://github.com/firebug/firebug/branches/firebug1.10/tests/content 1.10
https://github.com/firebug/firebug/branches/firebug1.11/tests/content 1.11
https://github.com/firebug/firebug/branches/firebug1.12/tests/content 1.12
https://github.com/firebug/firebug/trunk/tests/templates templates

Though that probably doesn't make any difference.

Sebastian

[1] http://stackoverflow.com/questions/18397990/svn-warning-w155010
[2] http://web.archiveorange.com/archive/v/FMIHj5PcwbPTr0tS8vXj
Flags: needinfo?(sebastianzartner)
(Assignee)

Comment 6

3 years ago
the swarm directory that was present was a git repo checkout and that had svn all confused. what i have done is update the external to checkout a directory called swarms.github then symlinked that swarms.github/trunk/ to a swarms directory for the application.

 [root@genericadm.private.phx1 getfirebug]# ls -ld swarms
 lrwxrwxrwx 1 root root 20 Oct 21 15:22 swarms -> swarms.github/trunk/


the update script is now much more happy and the externals appear to be working \o/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

3 years ago
Tested this in https://github.com/firebug/swarms/commit/18a532f1ff about an hour ago. And while the external in the SVN repo got updated correctly, the change isn't synchronized with the server, which I expected at https://getfirebug.com/swarms/Firefox-35.0/.

So it doesn't seem to be fixed for me yet, unfortunately. Any error on the server side? How are the 'tests' externals (SVN path: https://svn.mozilla.org/projects/getfirebug.com/tags/production/tests) tied in? 

Sebastian
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

3 years ago
from what i can tell, the swarms directory is current and the checkout is not returning any errors.

[root@genericadm.private.phx1 swarms]# svn info
Path: .
Working Copy Root Path: /data/genericrhel6/src/getfirebug.com/swarms
URL: https://github.com/firebug/swarms
Repository Root: https://github.com/firebug/swarms
Repository UUID: e2b72004-6c42-b917-8b7b-ce57b7db7bff
Revision: 14
Node Kind: directory
Schedule: normal
Last Changed Author: sebastian.zartner
Last Changed Rev: 14
Last Changed Date: 2014-10-23 23:21:10 -0700 (Thu, 23 Oct 2014)

[root@genericadm.private.phx1 swarms]# ls -d trunk/Firefox-35.0/
trunk/Firefox-35.0/
(Reporter)

Comment 9

3 years ago
Looks ok. Though the change doesn't appear online. So maybe the server mapping is incorrect?
Just to be clear, by my change I would expect to see a small 't' in 'Install The Swarm!' at https://getfirebug.com/swarms/Firefox-35.0/.

Sebastian
(Assignee)

Comment 10

3 years ago
i should have this sorted out now! the way the update script was running, it wasn't in the correct directory to `svn up` the externals. that should now be corrected!

 $ curl -s https://getfirebug.com/swarms/Firefox-35.0/ | grep -i "install the swarm"
  <button class="swarmCommand blue-pill" id="installSelected">Install the Swarm!</button><br><span id="extensionsSelected"></span>


i am going to mark this bug as r/fixed now, but please don't hesitate to reopen if you're seeing any other oddities with the swarms externals.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

3 years ago
Works for me now! Thanks a lot of your efforts and your patience on this, Chris!

Sebastian
You need to log in before you can comment on or make changes to this bug.