Intermittent test_switch_frame.py TestSwitchFrame.test_should_be_able_to_carry_on_working_if_the_frame_is_deleted_from_under_us | AssertionError: 0 != 1

RESOLVED DUPLICATE of bug 1078237

Status

defect
RESOLVED DUPLICATE of bug 1078237
5 years ago
5 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Disable one test and a new one starts failing in it's place. Maybe we should rename the harness to Hydranette.

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=840458&repo=fx-team

builder 	Windows 7 32-bit fx-team debug test marionette
buildid 	20141007112818
builduid 	78859cfa8e034056b29bd719eb8af5a7
results 	warnings (1)
revision 	4fa74ef900c5
slave 		t-w732-ix-116
starttime 	Tue Oct 07 2014 15:49:17 GMT-0400 (Eastern Standard Time)

12:55:50 INFO - TEST-START | test_switch_frame.py TestSwitchFrame.test_should_be_able_to_carry_on_working_if_the_frame_is_deleted_from_under_us
12:55:50 ERROR - TEST-UNEXPECTED-FAIL | test_switch_frame.py TestSwitchFrame.test_should_be_able_to_carry_on_working_if_the_frame_is_deleted_from_under_us | AssertionError: 0 != 1
12:55:50 INFO - Traceback (most recent call last):
12:55:50 INFO - File "C:\slave\test\build\tests\marionette\marionette\marionette_test.py", line 267, in run
12:55:50 INFO - testMethod()
12:55:50 INFO - File "C:\slave\test\build\tests\marionette\tests\testing\marionette\client\marionette\tests\unit\test_switch_frame.py", line 83, in test_should_be_able_to_carry_on_working_if_the_frame_is_deleted_from_under_us
12:55:50 INFO - self.assertEqual(0, len(self.marionette.find_elements("id", "iframe1")))
12:55:50 INFO - TEST-INFO took 691ms
Flags: needinfo?(dburns)
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(dburns)
Resolution: --- → DUPLICATE
Duplicate of bug: 1078237
You need to log in before you can comment on or make changes to this bug.