[Lockscreen] Single notification shows as scrollable on lockscreen when music player is present

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
6 months ago

People

(Reporter: bzumwalt, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-flame-test-run-3])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8501320 [details]
Screenshot

Description:
When user is playing music and has music player on lockscreen, recieving SMS or other notification on lockscreen shows a down arrow and scroll bar that implies that single notification can be scrolled. This is not the case and not until two more notifications are on screen until scrolling becomes an option.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141006000205
2) Launch music and select song to play
3) Press power button twice
4) Recieve SMS from second device
  
Actual:
On screen ui indicates that scrolling through single notifications is possible.
  
Expected: 
No indication that user can scroll through notifications until requisite amount of notifications to scroll are on screen.
  
Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141006000205
Gaia: 778ebac47554e1c4b7e9a952d73e850f58123914
Gecko: c4a4b04c617c
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 3/3, 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/13060/
See attached: screenshot & logcat
(Reporter)

Comment 1

4 years ago
Issue does NOT occur on Flame 2.2 KK (319mb) (Full Flash) or Flame 2.0 KK (319mb) (Full Flash)

Flame 2.2 KitKat Base (319mb)(Full Flash)
Device: Flame 2.2 Master
BuildID: 20141007040205
Gaia: 83de447d9ae9a59459d7a445f9348a254c661850
Gecko: 9ee9e193fc48
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.0 KitKat Base (319mb)(Full Flash)
Device: Flame 2.0
Build ID: 20141006000202
Gaia: 092d2b7678774c8b0b06dca0e0a8119e9eafdec3
Gecko: 69ca61f7edf3
Version: 32.0 (2.0)
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Actual Results: No indication that user can scroll through notifications until requisite amount of notifications to scroll are on screen.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(dharris)
Keywords: regression
Seems a dup since we solve this on master with Bug 1062695, and what the patch needs is only an approval. But I don't know whether we should uplift this (maybe not serious enough). We may discuss this with PM.
Not nominating this to block due to it being a minor UI bug.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 4

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.