Closed Bug 1079520 Opened 5 years ago Closed 5 years ago

GTest on mac gives XPCOMGlueLoad error 4:0 for file <GTEST XUL PATH>

Categories

(Testing :: General, defect)

x86
macOS
defect
Not set

Tracking

(firefox34 fixed, firefox35 fixed)

RESOLVED FIXED
mozilla35
Tracking Status
firefox34 --- fixed
firefox35 --- fixed

People

(Reporter: BenWa, Assigned: spohl)

References

Details

Attachments

(1 file)

STR:
Run ./mach gtest

Output:
XPCOMGlueLoad error 4:0 for file /Users/bgirard/mozilla/mozilla-central/builds/obj-ff-64gdb/dist/Nightly.app/Contents/MacOS/gtest/XUL:
image not found
Couldn't load XPCOM.

I can fix the problem by moving gtest/XUL from Resources to MacOS. Feels like the OSX coding signing stuff. Rob?

What I can't explain is why the tests are still running on BuildBot.
Flags: needinfo?(robert.strong.bugs)
spohl implemented these changes so redirecting the needinfo to him.
Flags: needinfo?(robert.strong.bugs) → needinfo?(spohl.mozilla.bugs)
I noticed this today as well. The build servers run the gtests during make check, which was fixed in bug 1053838. I'll look into this. Thanks for filing the bug!
Assignee: nobody → spohl.mozilla.bugs
Blocks: 1053820
Status: NEW → ASSIGNED
Flags: needinfo?(spohl.mozilla.bugs)
Depends on: 1053838
Attached patch PatchSplinter Review
This fixes './mach gtest' and also keeps 'make check' operational.
Attachment #8501439 - Flags: review?(benjamin)
Attachment #8501439 - Flags: review?(benjamin) → review+
https://hg.mozilla.org/mozilla-central/rev/c879f190a7fd
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Landed on aurora in the Mac V2 signing combined patch in bug 1047584
You need to log in before you can comment on or make changes to this bug.