Move the spidermonkey automation build scripts into the tree

RESOLVED FIXED

Status

Release Engineering
Mozharness
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: sfink, Assigned: sfink)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [easier-mozharness])

Attachments

(2 attachments, 3 obsolete attachments)

(Assignee)

Description

3 years ago
It's much easier to figure out what broke the tests if the build/run script is in the tree. And this seems to be the general direction of most things these days.
(Assignee)

Comment 1

3 years ago
Created attachment 8501410 [details] [diff] [review]
Move the automation build scripts into the tree
(Assignee)

Comment 2

3 years ago
Created attachment 8501413 [details] [diff] [review]
Call an in-tree script for spidermonkey jobs

Updated

3 years ago
Whiteboard: [easier-mozharness]
(Assignee)

Comment 3

3 years ago
Created attachment 8504826 [details] [diff] [review]
Call an in-tree script for spidermonkey jobs

Do the buildbot stuff, then run the script from the source tree.
Attachment #8504826 - Flags: review?(terrence)
(Assignee)

Updated

3 years ago
Attachment #8501413 - Attachment is obsolete: true
(Assignee)

Comment 4

3 years ago
Created attachment 8504827 [details] [diff] [review]
Move the automation build scripts into the tree

Move all the scripts into the tree.
Attachment #8504827 - Flags: review?(terrence)
(Assignee)

Updated

3 years ago
Attachment #8501410 - Attachment is obsolete: true
Comment on attachment 8504827 [details] [diff] [review]
Move the automation build scripts into the tree

Review of attachment 8504827 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/devtools/automation/autospider.sh
@@ +124,5 @@
> +fi
> +
> +$COMMAND_PREFIX $MAKE check || exit 1
> +$COMMAND_PREFIX $MAKE check-jit-test || exit 1
> +$COMMAND_PREFIX $MAKE check-jstests || exit 1

I guess this is the line that turns out to be a nop currently?
Attachment #8504827 - Flags: review?(terrence) → review+
Attachment #8504826 - Flags: review?(terrence) → review+
(Assignee)

Comment 6

3 years ago
Comment on attachment 8504826 [details] [diff] [review]
Call an in-tree script for spidermonkey jobs

Review of attachment 8504826 [details] [diff] [review]:
-----------------------------------------------------------------

Then again, r- from me. I just realized that if I land this as-is, I will break all of the spidermonkey builds for the older trees.
Attachment #8504826 - Flags: review+ → review-
(Assignee)

Updated

3 years ago
Keywords: leave-open
(Assignee)

Comment 7

3 years ago
Created attachment 8507237 [details] [diff] [review]
Call an in-tree script for spidermonkey jobs

Smaller patch. Call the in-tree version if it exists.
Attachment #8507237 - Flags: review?(terrence)
(Assignee)

Updated

3 years ago
Attachment #8504826 - Attachment is obsolete: true
Attachment #8507237 - Flags: review?(terrence) → review+
https://hg.mozilla.org/mozilla-central/rev/fde2ca8775f6
(Assignee)

Updated

3 years ago
Keywords: leave-open
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 912359
You need to log in before you can comment on or make changes to this bug.