massive menu bar madness

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
--
critical
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: SteveC, Assigned: Paul Chen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
look at http://www.fractalus.com/steve/tmp/moz.jpg

When I run moz 9.3 [ximian] after I have viewed a web page in Nautilus then
mozilla displays huge menu bar like this. If I remove the mozilla package and
kill all my ~/.mozilla files and install the latest talkback build I still get
the same thing. This makes mozilla unusable :-(

I realise this is probably the wrong catagory - but I couldn't think what would
be better. My user agent here is FreeBSD - because I can't use mozilla on the
Linux machine.

It doesn't happen to any other app I run.

Please help its driving me nuts!

Comment 1

16 years ago
wfm without using nautilus. Perhaps something is being set by gnome or nautilus
that is being interpreted by moz in a bad way. Reporter: please look for such a
thing, e.g. a pref, since I doubt there are more people like you seeing this.
OS->FreeBSD, Component->XP Apps.
Assignee: mpt → pchen
Component: User Interface Design → XP Apps
OS: Linux → FreeBSD
QA Contact: zach → sairuh

Comment 2

16 years ago
Same as bug 104432 or bug 104345

Comment 3

16 years ago
wfm too. I suspect this is some fontserver setup horkage. Same reported in bug
104345 and bug 100432. In 100432 reporter tells what he did to mend it.

From XF86Config manpage:
"Font path elements may be either absolute
directory paths, or a font server identifier."

On RedHat 7* which runs xfs to serve fonts (with xfsft) the correct approach is
to place this in /etc/X11/in XF86Config(-4)

Section "Files"
	FontPath "unix/:7100" 
EndSection

and then have the specific fontpaths listed in /etc/X11/fs/config

--

Reporter: Which fontserver/s are you running? And which Linux distribution?

Reporter in 104345 vaguely indicates he may have been running xfstt. If someone
runs xfs/xfsft in addition, and use truetype fonts, chances are there are two
servers "fighing" to serve TT fonts, with two completely differenc concepts
regarding font-scaling.

I have no idea if this can be the problem - just throwing in some ideas since
this has been reported three times now. However: The reports differ a lot wrt.
which version of Mozilla they see the bug in. Note that there was also a bug in
the Debian distro of moz (regarding fonts)- now corrected.

WFM with build ID 2001102910, Gnome 1.4 and Nautilus.
(Reporter)

Comment 4

16 years ago
Changed OS to linux - the machine with the bug is runnin that!

Debian 2.2r3 with X4.0.3 compiled by hand [not package] with ximian 1.4 latest
on top. It happens with ximian package [have not tried the Debian package] or if
I use a build off mozilla.org.

IIRC ttf is compiled into X4 now, and TTF fonts are enabled IIRC.

I will try the things suggested - including setting NS_FONT_DEBUG to 5 [as in
bug 104345] and report back tomorrow since the machine is at home, and the only
browser on it is mozilla.
OS: FreeBSD → Linux
okay, marking wfm for now --do reopen if still a problem!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
Ok so if I go System->Settings(gnome control center) then go to Theme select and
hit user font and choose arial [it was "default" helvetica] then the problem
goes away.

I gotta say that this should be left open as a mozilla bug since this problem
doesn't appear anywhere else, but I'm not familliar with the font system etc to
make a technical judgement so I leave it to you.

I attach the NS_FONT_DEBUG=5 output:


FindFont(a/0x0061), nsFontMetricsGTK.cpp 4011
    FindStyleSheetSpecificFont, nsFontMetricsGTK.cpp 3556
    FindStyleSheetGenericFont, nsFontMetricsGTK.cpp 3661
      user pref font.name.serif.x-western = adobe-times-iso8859-1,
nsFontMetricsGTK.cpp 3887
        TryNode aName = adobe-times-iso8859-1, nsFontMetricsGTK.cpp 3424
        load font adobe-times-iso8859-1, nsFontMetricsGTK.cpp 2894
loaded -adobe-times-medium-r-normal--16-*-0-0-p-*-iso8859-1

FindFont(a/0x0061), nsFontMetricsGTK.cpp 4011
    FindStyleSheetSpecificFont, nsFontMetricsGTK.cpp 3556
    FindStyleSheetGenericFont, nsFontMetricsGTK.cpp 3661
      user pref font.name.serif.x-western = adobe-times-iso8859-1,
nsFontMetricsGTK.cpp 3887
        TryNode aName = adobe-times-iso8859-1, nsFontMetricsGTK.cpp 3424
        load font adobe-times-iso8859-1, nsFontMetricsGTK.cpp 2894
loaded -adobe-times-medium-r-normal--32-*-0-0-p-*-iso8859-1

FindFont(a/0x0061), nsFontMetricsGTK.cpp 4011
    FindStyleSheetSpecificFont, nsFontMetricsGTK.cpp 3556
    FindStyleSheetGenericFont, nsFontMetricsGTK.cpp 3661
      user pref font.name.serif.x-western = adobe-times-iso8859-1,
nsFontMetricsGTK.cpp 3887
        TryNode aName = adobe-times-iso8859-1, nsFontMetricsGTK.cpp 3424
        load font adobe-times-iso8859-1, nsFontMetricsGTK.cpp 2894

FindFont(a/0x0061), nsFontMetricsGTK.cpp 4011
    FindStyleSheetSpecificFont, nsFontMetricsGTK.cpp 3556
    FindStyleSheetGenericFont, nsFontMetricsGTK.cpp 3661
      user pref font.name.serif.x-western = adobe-times-iso8859-1,
nsFontMetricsGTK.cpp 3887
        TryNode aName = adobe-times-iso8859-1, nsFontMetricsGTK.cpp 3424
        load font adobe-times-iso8859-1, nsFontMetricsGTK.cpp 2894
loaded -adobe-times-medium-r-normal--953-*-0-0-p-*-iso8859-1

FindFont(a/0x0061), nsFontMetricsGTK.cpp 4011
    FindStyleSheetSpecificFont, nsFontMetricsGTK.cpp 3556
    FindStyleSheetGenericFont, nsFontMetricsGTK.cpp 3661
      user pref font.name.serif.x-western = adobe-times-iso8859-1,
nsFontMetricsGTK.cpp 3887
        TryNode aName = adobe-times-iso8859-1, nsFontMetricsGTK.cpp 3424
        load font adobe-times-iso8859-1, nsFontMetricsGTK.cpp 2894
loaded -adobe-times-bold-r-normal--953-*-0-0-p-*-iso8859-1
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.