Browser doesn't show any content after generating several tabs

RESOLVED FIXED in Firefox 34, Firefox OS v2.0

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: pkj1020, Assigned: ting)

Tracking

({regression})

32 Branch
mozilla35
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(firefox33 wontfix, firefox34 fixed, firefox35 fixed, b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.124 Safari/537.36

Steps to reproduce:

1. visit a page 
2. tap number button of right top
3. tap plus 
4. select top most page (the page visited by 1)

try 2-4 several times rapidly (1 tab per 2 sec or so).



Actual results:

Some of the tabs don't show any content and reload doesn't work on these tabs.

Updated

4 years ago
Component: General → Gaia::Browser
(Reporter)

Comment 1

4 years ago
It seems that side-effect of below patch.

https://bugzilla.mozilla.org/show_bug.cgi?id=1057065 

It is also occurred on the Flame device.

Revert the commit, the problem is not reproduced.
(Reporter)

Updated

4 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
(Reporter)

Comment 2

4 years ago
Created attachment 8501577 [details]
20141008_164438.3gp
(Reporter)

Comment 3

4 years ago
Flame V2.0 build information

Gecko : commit 8aa6a54001a97eff2cde8c5a3e14e7ebe88199c3
Gaia : commit 31a49c7932c7085961760a6bef9ed381ea38d7e3

And I attached video file about the issue.
Please check it.
(Assignee)

Comment 4

4 years ago
Thanks for reporting.

nsFrameLoader::ReallyStartLoadingInternal() returns earlier for the tab not showing anything since ContentParent::GetNewOrUsed() returns null.

The problems has been resolved by bug 1040561 attachment 8473537 [details] [diff] [review], we should uplift it.
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
(Assignee)

Comment 5

4 years ago
NI Kanru for more information.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kchen)
(Assignee)

Updated

4 years ago
Component: Gaia::Browser → DOM: Content Processes
Product: Firefox OS → Core
Version: unspecified → 32 Branch
(In reply to Ting-Yu Chou [:ting] from comment #4)
> Thanks for reporting.
> 
> nsFrameLoader::ReallyStartLoadingInternal() returns earlier for the tab not
> showing anything since ContentParent::GetNewOrUsed() returns null.
> 
> The problems has been resolved by bug 1040561 attachment 8473537 [details] [diff] [review]
> [diff] [review], we should uplift it.

I think this is the only we need to uplift. Thanks for investigating!
Flags: needinfo?(kchen)
(Assignee)

Comment 7

4 years ago
Bhavana, should I request for approval here or in the original bug 1040561? Notes I need to uplift only a part of the patches and it needs rebase to v2.1 and v2.0.
Flags: needinfo?(bbajaj)
Attach the rebased patches here and ask for approval.
Flags: needinfo?(bbajaj)
(Assignee)

Comment 9

4 years ago
Created attachment 8502224 [details] [diff] [review]
patch for v2.1
Attachment #8502224 - Flags: review+
(Assignee)

Comment 10

4 years ago
Created attachment 8502228 [details] [diff] [review]
patch for v2.0

The patch is from bug 1040561, here we just rebase and uplift it.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 1033618 & bug 1057065
User impact if declined: browser app may fail opening web page and shows nothing
Testing completed: see bug 1040561
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: n/a
Attachment #8502228 - Flags: review+
Attachment #8502228 - Flags: approval-mozilla-b2g32?
(Assignee)

Comment 11

4 years ago
Comment on attachment 8502224 [details] [diff] [review]
patch for v2.1

The patch is from bug 1040561, here we just rebase and uplift it.

Approval Request Comment
[Feature/regressing bug #]: bug 1033618 & bug 1057065
[User impact if declined]: browser app may fail opening web page and shows nothing
[Describe test coverage new/current, TBPL]: see bug 1040561
[Risks and why]: low, it eliminates Nuwa fork waiting only
[String/UUID change made/needed]: n/a
Attachment #8502224 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

4 years ago
Assignee: nobody → tchou
Status: NEW → ASSIGNED
Comment on attachment 8502224 [details] [diff] [review]
patch for v2.1

I'm approving for Aurora. The merge to b2g34 is tomorrow. If this isn't uplifted in time, it will need to land on b2g34. Aurora+

Bhavana will handle the approval request for b2g32.
Attachment #8502224 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/75cd3a8fa031
status-b2g-v2.1: affected → fixed
status-b2g-v2.2: --- → fixed
status-firefox33: --- → wontfix
status-firefox34: --- → fixed
status-firefox35: --- → fixed
Depends on: 1040561
Target Milestone: --- → mozilla35
Comment on attachment 8502228 [details] [diff] [review]
patch for v2.0

Approving, as this is a fallout from https://bugzilla.mozilla.org/show_bug.cgi?id=1057065 in 2.0
Attachment #8502228 - Flags: approval-mozilla-b2g32? → approval-mozilla-b2g32+

Updated

4 years ago
Keywords: regression
(Assignee)

Comment 15

4 years ago
Set resolved since 1) https://groups.google.com/forum/#!topic/mozilla.dev.b2g/6yXyVSHAxJo, and 2) the patch has been landed on m-c in bug 1040561.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

4 years ago
Hi Sheriff,

I am sorry that I set checkin-needed here, but it has been two days after receiving approval for the patch of v2.0. I am not sure is it because I set the flags wrong, or there's anything I missed. I have read the mail in comment 15 for the uplift rules, are they changed?

BTW, there's also a patch in bug 997909 receives approval and needs uplift. Thank you.
Keywords: checkin-needed
Relax, it's in the bug queries for uplift. We've just been extremely backlogged this week.
Keywords: checkin-needed
(Assignee)

Comment 18

4 years ago
I see, thank you :)

Comment 21

4 years ago
Verify passed, this issue can't be repro on Woodduck 2.0;Flame2.0&2.1&2.2.
Attached: Verify_Woodduck_Browser.mp4
Reproducing rate: 0/5

Woodduck 2.0 Build:
Gaia-Rev        60146ec47cd38a8be8ed22e0116902eceb9ac067
Gecko-Rev       cdfbe9866cf0b71b33454926638ce0cd8bb1fb00
Build-ID        20141117050313
Version         32.0

Flame 2.0 build:
Gaia-Rev        086a668942292168f312b3bb53e275fa0886fab1
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/a57b299c5cf2
Build-ID        20141117000200
Version         32.0

Flame 2.1 build:
Gaia-Rev        81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/3572aa3e6766
Build-ID        20141117001201
Version         34.0

Flame2.2 build:
Gaia-Rev        ae3a84acaab80a5b35d5542d63e68462273c8a1b
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2d0a51ef828d
Build-ID        20141117160200
Version         36.0a1
status-b2g-v2.0: fixed → verified
status-b2g-v2.0M: fixed → verified
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified

Comment 22

4 years ago
Created attachment 8524458 [details]
Verify_Woodduck_Browser.MP4
You need to log in before you can comment on or make changes to this bug.