"My Submission" option is not visible

RESOLVED WONTFIX

Status

Marketplace
General
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: anil.ak.kumar, Unassigned)

Tracking

2014-Q4
Points:
---

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Case1:
    Load Marketplace Landing page https://marketplace-dev.allizom.org/en-US/

    Marketplace homepage is displayed. Verify that there are no format, layout issues.Verify that the Home Page shows the following:
    a) Header containing:
    - Firefox Marketplace logo
    - Search box
    - Main navigation button
    b) Main navigation menu containing: "Home", "New", "Popular" and "Categories". When the Categories link is hovered, a box is displayed containing 2 columns with app categories, each with its representative icon
    c) Marketplace feed displayed on 3 columns, containing collections and featured apps
    d) Footer containing:
    - Develop Apps button that redirects the user to Developer Hub
    - "Developer Hub", "Feedback", Chosen flag icon and region, "My Apps", "My Submissions"
-----------------------------------------------------------------------------
Case2:


    Load Marketplace Landing page https://marketplace-dev.allizom.org/en-US/

    Mozilla Marketplace homepage is loaded.
    There is a button on the top right page (gear wheel) that opens the main navigation containing:
    - {email} Edit Account Settings
    - My Apps
    - My Submission
    - Feedback
    - Sign Out
    Each link loads the respective option landing page.
    The navigation menu closes if the mouse is hovered outside it.




Actual results:

Case1: In the footer "My Submissions" options is missing
Case2: when user selects "gear wheel"(setting) icon, the option "My Submission" is not shown


Expected results:

As per test case "My Submissions" options should be shown

Comment 1

4 years ago
You are not visiting a valid URL, you are visiting a broken link. The 404 page does not have those links on it by design.

We'll fix this in bug 972495.

The homepage for the Marketplace is https://marketplace.firefox.com, the homepage for the developer hub is https://marketplace.firefox.com/developers
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.