The src of homescreen iframe is really long

RESOLVED FIXED in 2.1 S6 (10oct)

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: ting, Assigned: kgrandon)

Tracking

unspecified
2.1 S6 (10oct)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1076605 +++

This is spin off from bug 1076605 comment 14 that the src of homescreen iframe becomes really long after MTBF. It's like:

<iframe mozallowfullscreen="true" mozbrowser="true" name="main" remote="true" mozapp="app://verticalhome.gaiamobile.org/manifest.webapp" mozapptype="homescreen" src="app://verticalhome.gaiamobile.org/index.html#root14125903796341412590449855141259048842214125905102011412590515486141259053118314125905331261412590545761141259056248614125905841181412590589484141259062526614125906631821412590709327141259074238114125907671791412590792050141259081968914125908405121412590853337141259087424114125908795801412590906445141259092344014125909254061412590930912141259096273214125909961861412591021904141259104851014125910712681412591092072141259109...

The numbers are Date added from:

  http://lxr.mozilla.org/gaia/source/apps/system/js/homescreen_window.js#198

Note changing the src triggers aw__handle_mozbrowserlocationchange() which changes this.config.url, so the Date will actually be appended and create the long src.
(Reporter)

Comment 1

4 years ago
NI Alive as he owns the code.
Flags: needinfo?(alive)
Kevin could you take care this one?
Flags: needinfo?(alive) → needinfo?(kgrandon)
(Assignee)

Comment 3

4 years ago
Funny. Sure, doesn't seem too bad to fix.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kgrandon)
Target Milestone: --- → 2.1 S6 (10oct)
(Assignee)

Updated

4 years ago
Whiteboard: [systemsfe]
(Assignee)

Comment 4

4 years ago
Created attachment 8501812 [details] [review]
Github pull request
Comment on attachment 8501812 [details] [review]
Github pull request

Nice catch, looks good to me
Attachment #8501812 - Flags: review+
(Assignee)

Comment 6

4 years ago
In master: https://github.com/mozilla-b2g/gaia/commit/11ef00785cf933165fa021d7a46b95a27c1600d6
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

4 years ago
I guess we need the patch to be uplifted, the src grows to 1.x MB while running MTBF on v2.1.
(Assignee)

Comment 8

4 years ago
Comment on attachment 8501812 [details] [review]
Github pull request

Requesting uplift per comment 7.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): I think this has been here forever.
[User impact] if declined: Increased memory usage over time, you can see this just by pressing the home button a few hundred times.
[Testing completed]: Manual and unit tests.
[Risk to taking this patch] (and alternatives if risky): Low risk, 2 line change.
[String changes made]: None.
Attachment #8501812 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8501812 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/ecf10447e686e4236768e7d8ec2d6ffc161d4961
status-b2g-v2.1: affected → fixed
status-b2g-v2.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.