[v2.2] Usage information missing from utility tray footer after limit breach

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
4 years ago
a year ago

People

(Reporter: RobertC, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fromAutomation][NaBfT])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8501707 [details]
logcat.txt

test_cost_control_data_alert_mobile is failing intermittently on Jenkins:
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.smoke/39/HTML_Report/

I was not able to reproduce the issue manually.
Reproduction rate with automation: 1 out of 10

I attached the logcat from when the test was failing locally.

When the test fails there is not cost control message in the footer of the utility tray.

Build info:
Device firmware (date) 	07 Oct 2014 16:16:20
Device firmware (incremental) 	eng.cltbld.20141007.191609
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	07 Oct 2014 06:32:28
Gaia revision 	9050edcda308
Gecko build 	20141007160202
Gecko revision 	0c8ae792f1c0
Gecko version 	35.0a1

Due to the intermittent nature of the failure I cannot create a regression window.
(Reporter)

Comment 1

4 years ago
Created attachment 8501708 [details]
costcontrol.png

Comment 2

4 years ago
Robert, can you splice out from the Jenkins logcat the portion that includes just this test?

I imagine there might be some error messages around this frame failing to load.
Flags: needinfo?(robert.chira)
(Reporter)

Comment 3

4 years ago
Zac, the logcat I attached is from my local run and it only includes 1 test run.
Would you like me to also add the logcat from Jenkins?
Flags: needinfo?(robert.chira)

Comment 4

4 years ago
Oh my apologies Robert, I didn't see that :)

Local run is fine!
(Reporter)

Updated

4 years ago
Summary: [v2.2] Investigate test_cost_control_data_alert_mobile intermittent failure → [v2.2] Usage information missing from utility tray footer after limit breach
(Reporter)

Comment 5

4 years ago
Link to failing test:
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/cost_control/test_cost_control_data_alert_mobile.py

There are multiple errors visible in the logcat.
Could someone please take a look at this?
Flags: needinfo?(salva)
Flags: needinfo?(21)

Updated

4 years ago
Component: Gaia::UI Tests → Gaia::Cost Control
(Reporter)

Updated

4 years ago
Keywords: qawanted
Whiteboard: [fromAutomation]
(Reporter)

Comment 6

4 years ago
Can someone try and see if this issue can be manually reproduced?
This bug does NOT repro on Flame kk build: flame 2.2 KK, Flame 2.1 KK, Flame 2.0 KK

Actual Result: Unable to get the message about Data limit to disappear permanently from the bottom of the utility tray using Manual Testing. When I open the tray, the it's missing for a second then populates.

Repro Rate: 0/12

Environmental Variables:
Device: Flame Master KK
BuildID: 20141007183418
Gaia: 0bc74ce502672cf0265b24cf3a25d117c3de5e71
Gecko: e4cfacb76830
Version: 35.0a1 (Master) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141008055818
Gaia: 7ef2e1e59637a34ca4489c329b3bdee93df3ac6c
Gecko: e3d495eb85c6
Version: 34.0a2 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141008010820
Gaia: 14b50318e1f3cdd571566316acb49a4451d7a0af
Gecko: 38272cbff5de
Version: 32.0 (2.0) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: qawanted

Comment 8

4 years ago
This might be an automation race condition and possibly caused by bug 994190.

RobertC, can you do a quick check on the m-c builds between between 28th Sep and 30th September (ensuring they include the patch from bug 994190) exhibited this issue? If so then we can blame bug 994190.
Flags: needinfo?(robert.chira)

Comment 9

4 years ago
RobertC, check within these ranges:
Last m-c before bug 994190: 20140929040202 https://tbpl.mozilla.org/?showall=1&rev=8892214038df
First m-c with bug 994190: 20140929160203 https://tbpl.mozilla.org/?branch=mozilla-central&rev=7c24470b6b3a
(Reporter)

Comment 10

4 years ago
Zac, I ran the test on both builds from comment 9 and it still failed intermittently.
Flags: needinfo?(robert.chira)
The only things could be failing are SIM simulator or maybe the Gecko part for alarms. I can not reproduce locally and I can not debug the behavior.
Flags: needinfo?(salva)
Flags: needinfo?(21)
Whiteboard: [fromAutomation] → [fromAutomation][NaBfT]
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.