Cannot set focus on a field in JavaScript eventHandler fucntion

VERIFIED DUPLICATE of bug 109962

Status

()

--
blocker
VERIFIED DUPLICATE of bug 109962
17 years ago
17 years ago

People

(Reporter: njyang, Assigned: joki)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
in Netscape 6, forms's field.focus() method does not work. 

<input type="text" name="field1" onBlur="myHandler(this);>
function myHandler( field )
{
  //dosome validation here...
  if ( failed) {
    field.focus();
    return false;
  }
  else 
    return true;
}

Comment 1

17 years ago
Which Netscape version are you using? Can you reproduce in a Mozilla build (this
is Mozilla's bug database)?

Comment 2

17 years ago
Created attachment 56114 [details]
Reduced testcase

Comment 3

17 years ago
I believe I have captured the bug in the reduced testcase. 

Confirming bug. In NN4.7 and IE4, the upper textbox steals the focus
as soon as you type more than three characters in it. Using Mozilla
trunk binaries20011030xx on WinNT, Linux, however, the upper textbox
never steals the focus no matter how many characters you type -


OS : Win ---> All. This is not JS Engine; reassigning to DOM Level 0.
Assignee: rogerl → jst
Status: UNCONFIRMED → NEW
Component: Javascript Engine → DOM Level 0
Ever confirmed: true
OS: Windows NT → All
QA Contact: pschwartau → amar
Over to event handling.
Assignee: jst → joki
Component: DOM Level 0 → DOM Events
QA Contact: amar → vladimire
This looks like the same thing as bug 109962.  I'm duping up because it has an
even further reduced testcase.
I mean it this time :)

*** This bug has been marked as a duplicate of 109962 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.