All users were logged out of Bugzilla on October 13th, 2018

Messages are not threaded properly.

RESOLVED INVALID

Status

--
minor
RESOLVED INVALID
17 years ago
14 years ago

People

(Reporter: meheler, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011031
BuildID:    2001103108

See the linked-to screenshot. In thread-mode, messages are being put as replies
of other messages they have nothing to do with. This is in an IMAP folder, if it
makes any difference.

Reproducible: Sometimes
Steps to Reproduce:
1. Join a high-volume mailing list.
2. Create a separate folder for this mailing list.
3. Set up a filter that moves all mail to this folder.
4. Enable thread mode, wait, and watch.


Actual Results:  It seems almost random, in that some threads work fine, others
do not.

Expected Results:  Only have messages with the same subject line, or Re: subject
line in a thread. I don't know how else this would be done with email (as
opposed to newsgroups).
(Reporter)

Comment 1

17 years ago
Created attachment 56182 [details]
A screenshot image displaying the bug.

Updated

17 years ago
QA Contact: esther → laurel

Comment 2

17 years ago
This could happen if a user presses reply to a thread and then clears the
subject and writes a totally new message.

The References: header still refers to the old thread, but the user doesn't
realize that.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
ugh. enter submitted the form for some reason :-/

marking invalid unless reporter can reproduce this and include the message
headers for the relevant thread

this problem is usually caused by user error ... incorrect threading ususually
manifests itself in other ways
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.