Closed Bug 1080076 Opened 5 years ago Closed 5 years ago

[Rocketbar] Rocketbar sometimes becomes unresponsive after watching videos on youtube.com

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 affected, b2g-v2.2 unaffected)

RESOLVED WORKSFORME
2.1 S7 (24Oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected

People

(Reporter: rmead, Assigned: daleharvey)

References

()

Details

(Whiteboard: [2.1-flame-test-run-3][systemsfe])

Attachments

(1 file)

Attached file Flame2.1logcat.txt
Description:
If you go to youtube and watch a few videos, then go back and access the settings menu, sometimes the rocketbar will become unresponsive.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141008000201
2) Tap on Rocketbar and go to youtube.com
3) Watch a few random videos
4) Tap home button to return to homescreen
5) Open 'Settings' and select some random options
6) Tap home button to return to homescreen
7) Tap the left side of notification bar to open rocketbar  

Note: If the rocketbar still works, repeat steps 3-7 again.


Actual:
The screen will darken, but there will be no text box and the keyboard will not prompt.
  
Expected: 
The rocketbar opens normally with the text box and keyboard intact.
  

Flame 2.1(319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141008000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes: If you tap the rocketbar in the notification tray while in 'Settings' menu, the button will be unresponsive. If the phone locks while this bug is occurring, when you unlock the phone, the screen will be blank and there will be no way to exit other then pulling the battery (Home button and power button both become unresponsive).
  
Repro frequency: 66%
See attached: logcat, video - http://youtu.be/tmtCCDUNlqk
This issue does NOT occur on Flame 2.2 (319mb)

After watching some videos on youtube and exploring the Settings menu, the rocketbar remains responsive.

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141008040203
Gaia: 0bc74ce502672cf0265b24cf3a25d117c3de5e71
Gecko: e4cfacb76830
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0



The issue does NOT occur on Flame 2.0 (319mb) because v2.1 and above had a new rocketbar UX implemented.

Device: Flame 2.0 KK (319mb) (Full Flash)
BuildID: 20141008000202
Gaia: 31a49c7932c7085961760a6bef9ed381ea38d7e3
Gecko: a2d707e79061
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.1-flame-test-run-3] → [2.1-flame-test-run-3][systemsfe]
Removing the regressionwindow-wanted keyword, as the rocketbar did not exist within separate apps for branches earlier than 2.1 as mentioned in comment 1.

[Blocking Requested - why for this release]:

The Rocketbar should be available and functional in all apps. Although this is a low repro rate, it is possible to hit a bug that requires the user to pull the battery to recover. Nominating this for 2.1? blocking
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Assignee: nobody → dale
blocking-b2g: 2.1? → 2.1+
Target Milestone: --- → 2.1 S7 (Oct24)
on 2.1 I havent been able to reproduce this yet, still trying
Need QA support as engineer has been unable to repro
Keywords: qawanted
https://bugzilla.mozilla.org/show_bug.cgi?id=1081231 is also related, and went from reproducable to non reproducable with similiar symptoms
I'm also unable to reproduce this issue in the build below. I used to reproduce this issue last week but we also had white screen problems when loading apps. I seem to remember it was only after experiencing the white screen problem that I would see the rocketbar lock up as well.

In any event, I'm unable to reproduce. 0/12 tries.

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141014002300
Gaia: c1fef90cdbb82410b0f3f7d9f76c4fd07a2623cc
Gecko: 8d94c98e75f8
Version: 34.0 (2.1)
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
+1 for WFM
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Lets reopen if it comes back.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.