need tabs backup and restore menu items

RESOLVED WONTFIX

Status

()

Firefox
Session Restore
--
enhancement
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

32 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

I need "Backup Tabs" and "Restore Tabs" menu items, to/from a file.
this would make things a lot safer then stuff is in transition, or for development & testing, and just for general use, or for times when you have multiple environments you want to load up (could be good for work environments too! might improve productivity). This would be in addition to the auto tabs backup/restore functionality of reset button.


Actual results:

lost tabs after reset due to bug in ff, could have been preventable 


Expected results:

"Backup Tabs" and "Restore Tabs" menu items should be there to facilitate manual backup and restore of tabs database. could be as simple as copying the database itself if it's standalone or archiving/zipping/packaging the database and related files?
would have to take the sessions(?) db offline first to maintain integrity of the database before backup or restore, and reconnect afterwards.
(Reporter)

Updated

3 years ago
Severity: normal → enhancement

Comment 1

3 years ago
Like the "Session Manager" addon?
https://addons.mozilla.org/firefox/addon/session-manager/
Component: Untriaged → Session Restore
OS: Windows 7 → All
Hardware: x86_64 → All
You can always just zip $profile_dir/sessionstore* and save that as the backup, that's how I do it occasionally before testing something. Exposing a more sophisticated session management to the average user doesn't sound worthwhile but there is indeed the Session Manager add-on as mentioned by Yang above. It unfortunately does a lot of unnecessary additional stuff but it can take a snapshot of a session and restore that later on demand, which is I think what you want.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.