If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[System] Opened apps are never closed so overall device peformance drops drastically

RESOLVED INVALID

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-flame-test-run-3], [systemsfe], URL)

Attachments

(1 attachment)

Created attachment 8502099 [details]
MultipleAppsLog.txt

Description:
The user can open up an unlimited amount of apps which cause severe performance issues with the OS.

Repro Steps:
1)  Updated Flame to Build ID: 20141008000201
2)  Open up 10 apps and pay attention to the overall performance of the device. 
3)  Tap and hold the "home" button to open "card view". 
4)  Swipe through all the opened apps.

Actual:
All user opened apps remain open so performance of the phone drops drastically.

Expected:
After a certain number of apps are opened by the user, the oldest apps are closed so performance is not affected on the phone. 

Environmental Variables:
Device: Flame 2.1(KK)(319mb)(Full Flash)
Build ID: 20141008000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Version: 34.0a2 Flame 2.1 KK (319mb)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes:
Repro frequency: 100%
Link to failed test case: Found while exploratory testing.
See attached: logcat, video
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
[Blocking Requested - why for this release]: Auto-closing apps has regressed
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
See Also: → bug 1078786
(Reporter)

Updated

3 years ago
*note to window-worker - Issue is suspected to be full-flash specific
This is by design, all of the apps are removed but only the screenshot are left in task manager;
this should not block if there's no exact performance numbers.
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [2.1-flame-test-run-3], [systemfe] → [2.1-flame-test-run-3], [systemsfe]
clearing keywords
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.