Closed Bug 1080254 Opened 5 years ago Closed 5 years ago

[System Window Management] Letting the phone fall asleep in multiple apps causes an unresponsive blue screen once the user wakes the phone up

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

RESOLVED DUPLICATE of bug 1079995
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected

People

(Reporter: cnelson, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [systemsfe][2.1-flame-test-run-3])

Attachments

(1 file)

Attached file logcatbluescreen.txt
When the user lets the phone fall asleep while in multiple applications, the phone will wake to an unresponsive blue screen.  This issue has been reproduced in SMS app, Settings app, Contacts app, and the Dialer app.  Note that currently there are no solid repro steps.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141008000201
2) Open the SMS application.
3) Let the phone fall asleep while idling in the SMS application.
4) Shortly after the phone falls asleep, wake the phone up.
5) Unlock the phone on the lock screen.
6) Notice the phone may wake to an unresponsive blue screen.
  
Actual:
Phone wakes to an unresponsive blue screen after falling asleep in multiple applications.
  
Expected: 
Phone should wake without any issues after falling asleep in all applications.
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20141008000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 60%
See attached: logcat
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?]
Issue doesn't occur on 2.2 flame kk (319mb) (full flash) and  2.0 flame kk (319) (full flash)

Phone will wake without any issues after falling asleep in multiple applications.

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141008040203
Gaia: 0bc74ce502672cf0265b24cf3a25d117c3de5e71
Gecko: e4cfacb76830
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Device: Flame 2.0 KK (319mb) (Full Flash)
BuildID: 20141008000202
Gaia: 31a49c7932c7085961760a6bef9ed381ea38d7e3
Gecko: a2d707e79061
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
I saw this earlier today when testing - happened to me when I had the Dialer app open.
Whiteboard: [systemsfe][2.1-flame-test-run-3] → [systemsfe][2.1-flame-test-run-3][systemsfe]
Whiteboard: [systemsfe][2.1-flame-test-run-3][systemsfe] → [systemsfe][2.1-flame-test-run-3]
Duplicate of this bug: 1080632
[Blocking Requested - why for this release]:unresponsive screen encountered
blocking-b2g: --- → 2.1?
Flags: needinfo?(dharris)
I found 100% steps today:

1. Open the messages app.
2. Tap "..." and then tap on "Settings".
3. Hold down the home button to open card view and close out the "Settings" app.
4. Go back to the messages app and open settings again.

Notice that the status bar will be missing at the top of the settings page.

5. Lock the device and wake it back up.

Actual: The user will be stuck on a blank blue screen and will have to pull the battery to recover.
This then seems related to: bug 1079995
See Also: → 1079995
Bug 1074083 seems to have caused this issue.

Aurora Regression Window:

Last Working 
Environmental Variables:
Device: Flame 2.1
BuildID: 20141007165718
Gaia: e9b9ee15eded2671656efbc40f8437ae8a61d55c
Gecko: 49bd5bad84d2
Version: 34.0a2 (2.1) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken 
Environmental Variables:
Device: Flame 2.1
BuildID: 20141007195119
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Version: 34.0a2 (2.1) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: e9b9ee15eded2671656efbc40f8437ae8a61d55c
Gecko: 7fa82c9acdf2

First Broken gaia / Last Working gekko - Issue DOES occur
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 49bd5bad84d2

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/e9b9ee15eded2671656efbc40f8437ae8a61d55c...d71f8804d7229f4b354259d5d8543c25b4796064
Flags: needinfo?(jmitchell)
This issue has the exact same window / pushlog / regressing bug as 1079995 - closing as a dupe of that bug
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Resolution: --- → DUPLICATE
Duplicate of bug: 1079995
See Also: → 1080632
Duplicate of this bug: 1080632
You need to log in before you can comment on or make changes to this bug.