[2.1] A flash of black screen is seen before the FxA webflow loads

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
4 years ago
6 months ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

unspecified
x86
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Reporter)

Description

4 years ago
Connectivity: wifi
SIM used:
Gaia/device: flame/2.1 (20141006000205,2014-10-03 21:14:46, 778ebac4)


steps to reproduce:
1. Load marketplace-dev(iframed) app on your phone
2. Go to Settings page
3. Click on Sign in

observed behavior:
Flash of black screen before the webflow of fxa loads.

Behavior not seen on 1.4(2014-09-23, b06fee13)

screencast on 2.1: http://cl.ly/2d0r0O1u253M

screencast on 1.4: http://cl.ly/1v0c2G1H1Z2m

Updated

4 years ago
Component: Payments/Refunds → General
Product: Marketplace → Firefox OS
Version: 1.4 → unspecified

Updated

4 years ago
Priority: -- → P3
amckay - 
is this something that'll need fixing for 2.1 or 2.2? 
or do we need it investigated in order to land the current firefox accounts / marketplace integration...
Flags: needinfo?(amckay)

Comment 2

4 years ago
I don't know if its a bad problem or not. Seems an inconvenience to me, but not critical.
Flags: needinfo?(amckay)
Adding qawanted to do branch checks.
Keywords: qawanted
I can also see this problem with installed webapps, that are loading, I filed bug 1093671 for it.
Branch Check: 
(Flame, Full Flash, nightly, 319 MB memory)

Actual Results: When Signing-in to Marketplace app, the UI shows a transition between pages that includes a black screen.  This may be intended behavior. 

Note:  This appears to be intended behavior because each tested branch (2.0, 2.1, 2.2) has the same transition animation. This is illustrated in my attached video below. 

Video URL: http://youtu.be/JwH10VEDRt4

***If this is NOT intended behavior, then the following branches are affected, (FLame: 2.0, 2.1, 2.2) 

Device: Flame 2.2
BuildID: 20141107073659
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: b62ccf3228ba
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
----------------------------------------------
Device: Flame 2.1
BuildID: 20141107001205
Gaia: 6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko: 8c23b4f2ba29
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
----------------------------------------------
Device: Flame 2.0
BuildID: 20141107000206
Gaia: d3e4da377ee448f9c25f908159480e867dfb13f3
Gecko: 9836e9d81357
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: ddixon
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
QA Contact: ddixon

Updated

4 years ago
No longer blocks: 1007956

Comment 6

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.