[Window Mgmt] Canceling sharing a web link through email prevents user from attempting to share link again

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: bzumwalt, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-flame-test-run-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8502143 [details]
Logcat

Description:
When user cancels out of email compose screen after long pressing link in browser and sharing with email, user will no longer be able to share link until they force close email app in card view task manager. If user tries to share link again without doing this they will immediately be returned to web page.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141008000201
2) Launch browser and navigate to any website with a hyperlink visible
3) Long press link, select "Share Link" and choose "Email"
4) Tap back button to cancel out of compose email screen
5) Long press link on webpage and select "Share Link"
  
Actual:
User is taken back to webpage without notice.
  
Expected: 
User is taken to compose email screen with link pasted in body of email.
  
Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141008000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 3/3, 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/2029/
See attached: Youtube video clip & logcat
Youtube Link: http://youtu.be/SIV-zQ4OmsA
(Reporter)

Comment 1

4 years ago
Issue does NOT occur on Flame 2.2 KK (319mb) (Full Flash) or Flame 2.0 KK (319mb) (Full Flash)

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141008040203
Gaia: 0bc74ce502672cf0265b24cf3a25d117c3de5e71
Gecko: e4cfacb76830
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame 2.0 KK (319mb) (Full Flash)
BuildID: 20141008000202
Gaia: 31a49c7932c7085961760a6bef9ed381ea38d7e3
Gecko: a2d707e79061
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Actual Results: User is taken to compose email screen with link pasted in body of email.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(dharris)
Keywords: regression
I was able to get this issue to occur on the build it was reported on. Not able to reproduce this issue on todays 2.1 build. Marking as WFM.

Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.