Remove "Search with..." URLbar result

RESOLVED DUPLICATE of bug 1045985

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1045985
3 years ago
3 years ago

People

(Reporter: merfius, Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141001030205

Steps to reproduce:

Select URLbar, enter a query that is not part of a URL in your history.


Actual results:

"Query — Search with Google" is the first rich result.


Expected results:

This result should not appear.  If the user wished to search, they would have used the search bar rather than the URLbar, or simply hit enter after typing their query.  Forcing a redundant result in the first position decreases the number of useful visible results and hinders keyboard selection (requires an extra Tab to arrive at a relevant result).
(Reporter)

Updated

3 years ago
Blocks: 995091
This is by design, interaction will change once the design is complete, we are lacking pieces right now.
see bug 1045985.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1045985
You need to log in before you can comment on or make changes to this bug.