[traceback] MissingTokenError oauthlib.oauth2.rfc6749.parameters in validate_token_parameters

VERIFIED FIXED

Status

P1
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Assigned: mstriemer)

Tracking

Points:
---

Details

(URL)

(Reporter)

Description

4 years ago
steps to reproduce:
1. Tester is not logged in
2. Load https://payments-alt.allizom.org/purchases
3. Sign in using FxA


expected behavior:
Sign is successful without any errors and the user's installed apps list loads

actual behavior:
Sign is successful but there is a 500 and the installed apps fail to load

POST https://payments-alt.allizom.org/api/v2/account/fxa-login/ [HTTP/1.1 500 INTERNAL SERVER ERROR 600ms]
POST https://payments-alt.allizom.org/api/v2/account/fxa-login/ [HTTP/1.1 201 CREATED 1200ms]
"[req] POSTing" "https://payments-alt.allizom.org/api/v2/account/fxa-login/?lang=pt-BR&limit=25&region=us" include.js:8
"[req] Request failed:" "POST" 500 include.js:8
"[req] Response data: " "{"detail":"Internal Server Error"}" include.js:8
"[req] POSTed" "https://payments-alt.allizom.org/api/v2/account/fxa-login/?lang=pt-BR&limit=25&region=us" include.js:8
"[user] Setting new user token" includ

sentry: http://sentry.dmz.phx1.mozilla.com/marketplace-payments-alt/payments-altallizomorg/group/21256/

traceback details:


Stacktrace (chamada mais recente por último):

  File "rest_framework/views.py", line 396, in dispatch
    response = handler(request, *args, **kwargs)
  File "rest_framework/generics.py", line 414, in post
    return self.create(request, *args, **kwargs)
  File "mkt/account/views.py", line 108, in create
    data = self.create_action(request, serializer)
  File "mkt/account/views.py", line 215, in create_action
    userid)
  File "mkt/users/views.py", line 116, in _fxa_authorize
    client_secret=client_secret)
  File "requests_oauthlib/oauth2_session.py", line 180, in fetch_token
    self._client.parse_request_body_response(r.text, scope=self.scope)
  File "oauthlib/oauth2/rfc6749/clients/web_application.py", line 271, in parse_request_body_response
    self.token = parse_token_response(body, scope=scope)
  File "oauthlib/oauth2/rfc6749/parameters.py", line 303, in parse_token_response
    validate_token_parameters(params, scope)
  File "oauthlib/oauth2/rfc6749/parameters.py", line 313, in validate_token_parameters
    raise MissingTokenError(description="Missing access token parameter.")

Updated

4 years ago
Assignee: nobody → ashort

Updated

4 years ago
Priority: -- → P1
think this got fixed as part of something else.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
I just hit http://sentry.dmz.phx1.mozilla.com/marketplace-dev/marketplace-dev/group/21228/

I acn reproduce this with two accounts of mine.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

4 years ago
Assignee: ashort → mstriemer
(Assignee)

Comment 3

4 years ago
https://github.com/mozilla/fireplace/pull/732
Status: REOPENED → ASSIGNED
(Assignee)

Comment 4

4 years ago
https://github.com/mozilla/fireplace/commit/4db1a923be516611b3f930c02cddc30cbd1b6523
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

4 years ago
This was being caused by the clicking the "Sign In" button multiple times in the same session. I think that's why if you tested this bug it would work but it would happen while you were testing other login related bugs.
(Reporter)

Comment 6

4 years ago
steps to reproduce:
1. Log in to dev using FxA (I tried from the homepage and My apps page)


expected behavior:
Log in is successful
No 500s
No error messages shown

actual behavior:
Log in is successful
POST returns a 500
"Sign in failed" error is shown

sentry: sentry: http://sentry.dmz.phx1.mozilla.com/marketplace-dev/marketplace-dev/group/21228/

screencast: http://screencast.com/t/wKV38sLEW0

POST https://marketplace-dev.allizom.org/api/v2/account/fxa-login/ [HTTP/1.1 500 INTERNAL SERVER ERROR 414ms]
POST https://marketplace-dev.allizom.org/api/v2/account/fxa-login/ [HTTP/1.1 201 CREATED 591ms]
POST https://marketplace-dev.allizom.org/api/v2/account/fxa-login/ [HTTP/1.1 500 INTERNAL SERVER ERROR 773ms]
POST https://marketplace-dev.allizom.org/api/v2/account/fxa-login/ [HTTP/1.1 500 INTERNAL SERVER ERROR 2205ms]
POST https://marketplace-dev.allizom.org/api/v2/account/fxa-login/ [HTTP/1.1 500 INTERNAL SERVER ERROR 676ms]
"[req] POSTing" "https://marketplace-dev.allizom.org/api/v2/account/fxa-login/?lang=en-US&limit=25&region=us" include.js:8
"[req] Request failed:" "POST" 500 include.js:8
"[req] Response data: " "{"detail":"Internal Server Error"}"
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

4 years ago
Severity: normal → major
(Assignee)

Comment 7

4 years ago
I can't reproduce this. Are there any more STR?
Flags: needinfo?(krupa.mozbugs)
(Reporter)

Comment 8

4 years ago
I don't see the behavior from comment 6 anymore. Closing this as fixed for verification.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(krupa.mozbugs)
Resolution: --- → FIXED
(Reporter)

Comment 9

4 years ago
verified fixed at https://marketplace.allizom.org/purchases
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.