Enabling swipe to call feature when swiped on a contact

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Dialer
--
enhancement
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: kskarthik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140830211128

Steps to reproduce:

swiped rightside on a contact in both call log and contacts but no response. 


Actual results:

Tapped on the contact and it showed the details of the contact. 
It happened both for contacts and call log.


Expected results:

Please provide swipe right to call and swipe left to message feature when swiped on a contact & contact in call log
(Reporter)

Updated

3 years ago
Severity: normal → enhancement
Keywords: ateam-b2g-device-goal
OS: All → Gonk (Firefox OS)
Priority: -- → P1
Hardware: All → ARM
Whiteboard: enabling swipe to call feature when swiped on a contact
Severity: enhancement → normal
Component: Gaia::Contacts → Gaia::Dialer
Keywords: ateam-b2g-device-goal
Priority: P1 → --
Hardware: ARM → All
Summary: Please enable swipe to call feature in call logs & contacts list → Enabling swipe to call feature when swiped on a contact
Whiteboard: enabling swipe to call feature when swiped on a contact
Hei Carrie, any opinion on this?

I'm thinking about the case of a contact with several phone numbers (or none), and also DSDS.
Flags: needinfo?(cawang)

Updated

3 years ago
Severity: normal → enhancement
Hi, 

Unfortunately, this is something we can't do. First of all, swipe to trigger actions is not a pattern in our system. Also, it may conflict with the "edge gesture. Secondly, this is a patent of other company, we will get into trouble if we adopt it. Thanks!
Flags: needinfo?(cawang)
Hi kskarthik91,

As Carrie said we can't do anything about this new feature, can you mark this bug as RESOLVED -> WONTFIX?

Thank you very much!
Flags: needinfo?(kskarthik91)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Flags: needinfo?(kskarthik91)
(Reporter)

Comment 4

3 years ago
(In reply to Johan Lorenzo [:jlorenzo] from comment #3)
> Hi kskarthik91,
> 
> As Carrie said we can't do anything about this new feature, can you mark
> this bug as RESOLVED -> WONTFIX?
> 
> Thank you very much!


Why ? android has this option. Since Fxos copies most of the ui from android. Why can't this option implemented ? This helps the user to make calls easier.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 5

3 years ago
Ok, atleast, dropdown menu when contact is clicked with options like call, message, add to contacts, This option already exists for numbers which are not stored in contacts. So make this menu appear also for numbers in the contacts.
Flags: needinfo?(kskarthik91)
Karthik,

As far as I know, the swipe to call/text (left,right) feature is only on Samsung's TouchWiz feature and not an android feature and in android systems itself to get this part of the contact apk you need to port the other touchwiz dependencies. So I guess the swipe method is a no-go because of the patent they hold unless permissions can be taken.

>Ok, atleast, dropdown menu when contact is clicked with options like call, message, add to contacts

This sounds nicer, you could have a layer like that of alert() holding these options and perform the required operation. 

If others are also fine with the idea, we have to put the ux team here to design that and put it in the design documentation before implementing them.

Whats your view Johan and Carrie ?
Flags: needinfo?(jlorenzo)
Flags: needinfo?(cawang)
Hi, 


I just wanna clarify something here. Design is not something this easy and artificial. We don't just "copy" other devices (if so, then this will be the easiest job in the world. Because other people already finished everything for you). We create our design pattern, building blocks and we receive different requests from PM, partners and contributors/ users on bugzilla (just like you). In addition, we need to consider release timeline and feasibility constraints, which means we need to do a lot of compromises when things are conflicting with each other. Taking this case for example, drop down menu is one of our design proposal originally (surprise! we do think.), but after several rounds of internal design review, there had two issues need to be considered. Firstly, drop down menu will be a new pattern and only be adopted in Contacts or Call log and it will make the whole system inconsistent. Secondly, adopting drop down menu will violate a patent held by other companies. Yes, drop down menu appears everywhere in this industry, how come it's a patent? It looks like in the real world, patent is something very tricky and contains a lot of knowledge/ deals in it. Some companies can share patents or buy patents, but this is not for Mozilla. We pursue the value of open source, which means we will face a lot of limitation during developing our OS. This is a difficult situation, but we try our best to conquer it. Maybe we are not doing perfectly now, but we will continue fighting for it. :)

Thanks for the suggestion here. It reminds us that we need to provide a quicker/ easier way for users to reach their contacts. Actually, we are currently trying some different design to achieve this goal. Maybe it is not happening now, but it will definitely come out soon in the future. So, hang in there! We get your painpoint and feel sorry for it! Thanks!
Flags: needinfo?(cawang)
I'm not in the UX team (I'm in the QA one), so Carrie is the one that can provide the best answer.
Flags: needinfo?(jlorenzo)
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago2 years ago
Flags: needinfo?(kskarthik91)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.