Closed Bug 1080472 Opened 5 years ago Closed 5 years ago

crash in nsUrlClassifierPrefixSet::CollectReports(nsIMemoryReporterCallback*, nsISupports*, bool)

Categories

(Core :: JavaScript Engine, defect, critical)

All
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1050108

People

(Reporter: cosmin-malutan, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-32c62f6c-f446-484c-b214-099042141009.
=============================================================


Latest Nightly crashed on OSX 10.7(mm-osx-107-2) in a mozmill tests testBackForwardNavigation/test1.js 

The log we had before crash;
>04:59:15 ###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xAA0001,name=PTexture::Msg___delete__) Route error: message sent to unknown actor ID
>04:59:15 
>04:59:15 
>04:59:15 ###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xAA0001,name=PTexture::Msg___delete__) Route error: message sent to unknown actor ID
>04:59:15 
>04:59:15 
>04:59:15 ###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xAA0001,name=PTexture::Msg___delete__) Route error: message sent to unknown actor ID
>04:59:15 
>04:59:15 
>04:59:15 ###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xAA0001,name=PTexture::Msg___delete__) Route error: message sent to unknown actor ID
>04:59:15 
>04:59:15 
>04:59:15 ###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0xAA0001,name=PTexture::Msg___delete__) Route error: message sent to unknown actor ID
>04:59:19 TEST-START | testBackForwardNavigation/test1.js | setupModule
>04:59:22 TEST-START | testBackForwardNavigation/test1.js | testNavigateBackForward
>04:59:33 mozcrash INFO | Saved minidump as /Users/mozauto/Library/Application Support/Firefox/Crash Reports/pending/AF212016-DA80-45D3-A3EE-60C5190712D1.dmp

The stack trace:
0 	XUL 	nsUrlClassifierPrefixSet::CollectReports(nsIMemoryReporterCallback*, nsISupports*, bool) 	obj-firefox/x86_64/dist/include/nsTArray-inl.h
1 	XUL 	nsMemoryReporterManager::GetReportsForThisProcessExtended(nsIMemoryReporterCallback*, nsISupports*, bool, __sFILE*) 	xpcom/base/nsMemoryReporterManager.cpp
2 	XUL 	nsMemoryReporterManager::GetExplicit(long long*) 	xpcom/base/nsMemoryReporterManager.cpp
3 	XUL 	NS_InvokeByIndex 	xpcom/reflect/xptcall/md/unix/xptcinvoke_x86_64_unix.cpp
4 	XUL 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp
5 	XUL 	XPC_WN_GetterSetter(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/xpcprivate.h
6 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/jscntxtinlines.h
7 	XUL 	js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value const*, JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
8 	XUL 	js::Shape::get(JSContext*, JS::Handle<JSObject*>, JSObject*, JSObject*, JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
9 	XUL 	GetPropertyHelperInline<1> 	js/src/vm/ObjectImpl.cpp
10 	XUL 	Interpret 	js/src/vm/ObjectImpl.cpp
11 	XUL 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
12 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
13 	XUL 	js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value const*, JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
14 	XUL 	js::CrossCompartmentWrapper::call(JSContext*, JS::Handle<JSObject*>, JS::CallArgs const&) const 	js/src/proxy/DirectProxyHandler.cpp
15 	XUL 	js::Proxy::call(JSContext*, JS::Handle<JSObject*>, JS::CallArgs const&) 	js/src/proxy/Proxy.cpp
16 	XUL 	js::proxy_Call(JSContext*, unsigned int, JS::Value*) 	js/src/proxy/Proxy.cpp
17 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/jscntxtinlines.h
18 	XUL 	Interpret
Group: core-security
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050108
You need to log in before you can comment on or make changes to this bug.