Closed Bug 1080473 Opened 6 years ago Closed 6 years ago

[Usage][Cost Control] (Temporary workaround) Noticeable difference between by application breakdown totals and the total displayed in chart and widget

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S7 (24Oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: salva, Assigned: salva)

References

Details

Attachments

(5 files)

Attached image usage-difference.png
[Blocking Requested - why for this release]:
The user could get confused for the "missed" mobile usage. Furthermore, the difference is huge pointing to a possible problem in the platform.

STR:
 1. Make reset-gaia 
 2. Don't enable any mobile data network.
 3. Launch Usage and pass the FTU with default values.
 4. Obvserve usage is 0
 5. Press home button
 6. Enable 3G from utility tray
 7. Keep home pressed and return to Usage application
 8. Wait for chart and application breakdown

Expected:
 Total amount of data displayed in the breakdown sums up the same amount displayed in the chart.

Actual:
  There is a noticeable difference between the two totals.
Comms triage: Shing, can you confirm you are also reproducing this bug?
Flags: needinfo?(slyu)
Keywords: qawanted
Comms triage: Feature broken, we need to fix it
blocking-b2g: 2.1? → 2.1+
I have tested it with today production build (not doing "make reset-gaia", just OTA update instead), and I can reproduce it.
Attached image Flame 2.1 (no repro)
I'm unable to reproduce this bug following exactly the steps. The attached screenshot on comment 0 shows some data had been consumed so I tried that as well. 

My observed result: No noticeable difference between app breakdown total and total displayed for 'Mobile usage'. See my attached screenshot. Bug repro rate: 0/4.

Tested on:
Device: Flame 2.1 (full/shallow flash)
BuildID: 20141010064105
Gaia: 883cb6c30f770a8a3aea59e66331d764b5d61307
Gecko: 11656eb0032d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Leaving qawanted tag for others to attempt.
I was unable to repro what the screenshot shows (15 MB).  However, here are the results I found for Flame 2.2, 2.1, and 2.0 builds.  (I tested each build 3 times.) 

2.2 Results: After turning on Data connection, the device immediately downloads an average of 70 KB of information. 

Device: Flame Master
Build ID: 20141011031924
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Version: 35.0a1 (Master)
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

2.1 Results:  After turning on Data connection, the device immediately downloads and average of 25  KB of information. 

Device: Flame 2.1
Build ID: 20141011053325
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: e05a92abe9a8
Version: 34.0a2 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

2.0 Results:  After turning on Data connection, the device immediately downloads an average of 60 KB of information. 

Device: Flame 2.0
Build ID: 20141010074705
Gaia: 6effca669c5baaf6cd7a63c91b71a02c6bd953b3
Gecko: 54ec9cb26b59
Version: 32.0 (2.0)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA-Wanted department has been unable to reproduce this issue - 

In the past there have been a few differences that get called out as being suspected why parties are getting different results 

- We have AT&T sims - so this might be sim dependent
- Our network is not technically 3G - it's H which is 3G equivalent (or 3.2G) but might make a difference
Flags: needinfo?(jmitchell)
(In reply to Maria Angeles Oteo (:oteo) from comment #1)
> Comms triage: Shing, can you confirm you are also reproducing this bug?

Confirmed. 

The chart and the notification bar shows 167.52 KB
The per-app list has only one "System" which uses 82.02 KB, The "Data usage" section in Settings also shows 82.02 KB (I'll attach the screenshots.)

I also notice that when I unlock the screen to show the settings page, the usage will jump from 82.02 KB to 167.52 KB for about 0.5 seconds and jump back to 82.02 KB. 

I use a ChungHua Telecom card, it also connects to H(SDPA). I suspect there may have been issues when the connections jump between 3G and H, but I dont' have the equipment to test that.

Version:
Gaia      d1d176fb83f996f7460e6fcaf012fce23e52e4bd
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/b2f2db1efe4d
BuildID   20141002160203
Version   34.0a2
ro.build.version.incremental=eng.cltbld.20140929.194231
ro.build.date=Mon Sep 29 19:42:41 EDT 2014
Flags: needinfo?(slyu)
Attached image Usage Mismatches
Assignee: nobody → salva
Status: NEW → ASSIGNED
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Attached file FE patch
Hi, 
salva, would you giving me your feedback about this patch?
This patch is developed as a temporary solution, the idea is sum the difference of the traffic to the system app. WDYT?
Regards
Attachment #8504744 - Flags: feedback?(salva)
Comment on attachment 8504744 [details] [review]
FE patch

Working fine. Please address my comments on GitHub but it looks nice. Thank you very much Marina.

Peter, this is a front-end workaround folding the residual traffic onto the System application but the decision is up to you. What should we do?
Attachment #8504744 - Flags: feedback?(salva) → feedback+
Flags: needinfo?(pdolanjski)
Since this is already marked as a blocker, I think we're good to move forward with this solution.
Flags: needinfo?(pdolanjski)
Comment on attachment 8504744 [details] [review]
FE patch

You have a couple of nits on GitHub about comments but it LGTM and attending to comment 11, we can go with this workaround.

As this bug will be marked as solved, **before merging**, file a new one highlighting the platform bug and change the references in your comments to this bug.

Thank you! Don't forget to ask for approval.
Attachment #8504744 - Flags: review+
Blocks: 1083680
Master: 2059503549642b9d07d13b85c20a5b54801a202e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8504744 [details] [review]
FE patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature
[User impact] if declined: Data inconsistency, noticeable difference between app breakdown total and total displayed for 'Mobile usage'. This could be confused for the user.
[Testing completed]: Yes, on device
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]: No
Attachment #8504744 - Flags: approval-gaia-v2.1?(release-mgmt)
Attachment #8504744 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1+
Issue still occurs on Flame 2.2 and Flame 2.1 
Data usage shows different information on "Usage" page and "Settings" comparing to "Notification bar" (See the screenshot), seems like "Usage" page is slower to update the usage

Device: Flame 2.1
BuildID: 20141023001201
Gaia: 1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko: 09fb60a37850
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

"Flame 2.2" 

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141023040204
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 88adcf8fef83
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage?][failed-verification]
Attached image issueOn2.1and2.2.png
Flags: needinfo?(ktucker)
Hi,
the difference that are showed on the screenshot are normal because the refresh of the data traffic is different between the widget and the App. 
The widget is listening to network-events, this way the data traffic update on the widget is faster than on the App, this is possible because the widget is lighter than the app and only have to refresh a label, meanwhile, the app has to refresh some labels, graphics and the list of traffic by app, because of this, the app cannot be refreshed so often than the widget.
 
Besides, in both cases they are not updated when they are not visible for the user for performance reasons.
Shing, based on our findings in comment 16 and Marina's comment 18, is it okay to close out this issue as fixed?
Flags: needinfo?(ktucker) → needinfo?(slyu)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Since Marina's comment 18 said that the widget is handled differently from the app, I think we can mark this as fixed as long as the per-app breakdown total equals the chart and the number in the setting. 

sarsenyev, can you open a new bug for your findings? The difference the widget and the app is confusing for the user. Thanks.
Flags: needinfo?(slyu) → needinfo?(sarsenyev)
Summary: [Usage][Cost Control] Noticeable difference between by application breakdown totals and the total displayed in chart and widget. → [Usage][Cost Control] (Temporary workaround) Noticeable difference between by application breakdown totals and the total displayed in chart and widget
as per comment 20, opened a new bug 1089943 per delayed update, closing the defect as fixed
App breakdown total equals the chart and the number in the settings

Device: Flame 2.2 Master KK
BuildID: 20141027040237
Gaia: e91d99e4d96954f06383c00bb9d79598a697e310
Gecko: 8230834302c9
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1 KK
BuildID: 20141027001201
Gaia: c97463d61f45513a2123b19610386ddbfc916819
Gecko: 4f8c0c021128
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage?]
Flags: needinfo?(sarsenyev) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.