Upgrade to JSX 0.11.2

RESOLVED FIXED in Firefox 35

Status

Hello (Loop)
Client
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: andreio, Assigned: NiKo)

Tracking

unspecified
mozilla35
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox35 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10) AppleWebKit/600.1.25 (KHTML, like Gecko) Version/8.0 Safari/600.1.25

Steps to reproduce:

Update to latest react-tools. As of now 0.11.2
Run ./build-jsx
It uses a strict equality to check for the version


Actual results:

Error saying I need react-tools 0.11.1


Expected results:

It should have compiled my jsx sources

Updated

3 years ago
Component: Untriaged → General
Product: Firefox → Loop
QA Contact: anthony.s.hughes
We created it as a strict check because we were seeing whitespace differences across different versions, and didn't want to confuse the diffs too much with the extra whitespace info.
Status: UNCONFIRMED → NEW
Component: General → Client
Ever confirmed: true
Summary: JSX build script shouldn't use strict equality check → Upgrade to JSX 0.11.2
Created attachment 8503006 [details] [diff] [review]
Upgrade React to 0.11.2.
Attachment #8503006 - Flags: review?(mdeboer)
Assignee: nobody → nperriault
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Comment on attachment 8503006 [details] [diff] [review]
Upgrade React to 0.11.2.

Review of attachment 8503006 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. Thanks!
Attachment #8503006 - Flags: review?(mdeboer) → review+
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=bc492c8dc956
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/bc2f5abcf051
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/bc2f5abcf051
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla35
status-firefox35: --- → fixed
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.