Error 500 on a build page

RESOLVED DUPLICATE of bug 1069547

Status

P3
major
RESOLVED DUPLICATE of bug 1069547
4 years ago
4 years ago

People

(Reporter: sylvestre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [shipit])

Pretty sure this is due to the general DB issue's we've been seeing today.
Still happening, even on recently completed releases like
 https://ship-it.mozilla.org/releases/Firefox-31.2.0esr-build3/status.html
but doesn't affect releases which are only 'Submitted' (in staging), so probably fallout from one of zeller's changes.

bhearsum, do we need to throw this to WebOps to get the exception and/or database state ?
I've got access to the logs. I found this:
2014-10-13 03:31:36,982 - kickoff.log_exception#1306: Exception on /releases/Fennec-27.0b1-build1/status.html [GET]
Traceback (most recent call last):
  File "/data/www/ship-it.mozilla.org/release-kickoff/vendor/lib/python/flask/app.py", line 1687, in wsgi_app
    response = self.full_dispatch_request()
  File "/data/www/ship-it.mozilla.org/release-kickoff/vendor/lib/python/flask/app.py", line 1360, in full_dispatch_request
    rv = self.handle_user_exception(e)
  File "/data/www/ship-it.mozilla.org/release-kickoff/vendor/lib/python/flask/app.py", line 1358, in full_dispatch_request
    rv = self.dispatch_request()
  File "/data/www/ship-it.mozilla.org/release-kickoff/vendor/lib/python/flask/app.py", line 1344, in dispatch_request
    return self.view_functions[rule.endpoint](**req.view_args)
  File "/data/www/ship-it.mozilla.org/release-kickoff/vendor/lib/python/flask/views.py", line 83, in view
    return self.dispatch_request(*args, **kwargs)
  File "/data/www/ship-it.mozilla.org/release-kickoff/vendor/lib/python/flask/views.py", line 150, in dispatch_request
    return meth(*args, **kwargs)
  File "/data/www/ship-it.mozilla.org/release-kickoff/kickoff/views/status.py", line 94, in get
    errors = ['No release events found for {}'.format(releaseName)]
ValueError: zero length field name in format

This is the same as bug 1069547.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1069547
You need to log in before you can comment on or make changes to this bug.