mail that is partialy loaded doesn't finish loading

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: mozbug1, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101202

If a mail is selected, is partialy loaded, then another mail is selected, if I
go back to the first one it won't finish loading and will only display the part
that was partially loaded.  For example if I delte a message another mail is
selected.  If before that loads I click on a different mail I can't go back and
view the whole of the first one.  This is a little hard to reproduce, it would
help if you had a slow modem connection.

Reproducible: Sometimes
Steps to Reproduce:
1. Have three messages.
2. Delete one, causing another one to start loading.
3. Quickly click on the other message.

You could also reproduce this other ways, for example clicking on an email and
then quickly clicking on another.  Sometimes I hit a down arrow when reading
email expecting the message to scroll down, but accidentally move the mail
selection down through a  few emails, and the ones in the middle get partially
loaded.

(BTW is there an rfe that focus should transfer to the mail display window when
a mail is selected for reading?)

Actual Results:  The partially loaded message is stored in cache and mozilla
will not reload it.

Expected Results:  Should have reloaded the message from the server.

There should be a way of reloading mails just like web pages can be reloaded. 
It might help with another problem I've been having reading mail where it
appears a part in the middle was cut out.  If I could reload I could get around
the problem, and maybe finally chase it down so I could file a bug report.

I think this is a major problem, because it prevents certail emails from being
read and nobody who depends on email (and who doesn't?) can rely on mozilla
until this is fixed.

Comment 1

17 years ago
Confirmed on Solaris/SPARC, build 2001110210.

Isn't this a duplicate of 108114, or vice versa?

Comment 2

16 years ago
*** Bug 108114 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
is this still happening with recent builds?
OS: Linux → All

Comment 4

16 years ago
Not that I have been able to tell...

Comment 5

16 years ago
good to hear.
how about the reporter of this bug. do you still experience this problem?

Comment 6

16 years ago
I can cause this condition to occur again.   Mozilla win32 nightly build 2002040708.

View the message with a large inline image (GIFs are a good test case since they
will display as they load) in the preview pane.  Once it starts to load and
display, then double click the title in the thread view pane.  When it starts to
load in the new window it will halt the load in the preview pane as well,  and
enter into a state where it will no refetch the unfinished message.  (Continues
to show partial image.)
(Reporter)

Comment 7

16 years ago
I am not seeing the bug in the form I reported it in.  I do notice that when i
go back to the first email that it starts loading from the start again (bug 116365)?

Comment 8

16 years ago
Is this still happening in a current version?

pi
(Reporter)

Comment 9

16 years ago
Not as far as I can tell.

Comment 10

16 years ago
Calum, Thomas, can you still reproduce it?

pi

Comment 11

16 years ago
No, I've not seen this problem for a while. I've just tried to reproduce it and
all seems well.

Comment 12

16 years ago
WFM by comment 9 and comment 11.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
Comment #6 is still a problem

Comment 14

16 years ago
Thomas, in which version can you still reproduce it?

What do you mean by preview pane?

Can anybody else reproduce it with the given steps?

pi

Updated

15 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.