Correctly handle Serbian for both Desktop and Firefox OS

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: mat, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

4 years ago
Serbian language support in Marketplace doesn't fully work.

- Firefox OS sends "sr-Latn" language for Serbian. It's the only option, you can't choose the Cyrillic alphabet.
- Firefox Desktop sends "sr".

We have translations for both in our projects, so they are recognised (we consider "sr" is the Cyrillic version) and everything is translated.

The problem ? We only let developers change translations for their apps in "sr-Latn", and not "sr". That means a Firefox OS user will see the Serbian translations the app developer added, but not a Firefox Desktop user.

I don't see an easy fix. We might need to build a more complex fallback mechanism than what we currently have - currently, because "sr" is a valid locale, fireplace doesn't try to expand it to "sr-Latn" - it doesn't know that the apps can't be translated in "sr".
(Reporter)

Comment 1

4 years ago
Correction : I was wrong, we do let developers add a translation for "sr". 

So, the problem is:
- If a developer only adds a translation for "sr", Firefox OS users won't see a Serbian translation

- If a developer only adds a translation for "sr-Latn", Firefox Desktop users won't see a Serbian translation

I don't know how big a problem that is, maybe this is not such a big deal after all ?
(Reporter)

Comment 2

4 years ago
I need glasses. I also had not seen "Српски" in the language settings in Firefox OS.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.