[Camera] While phone is recording, checking the utility bar and pressing the home button causes lag and text sticking issues

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: rmitchell, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-flame-test-run-3], URL)

Attachments

(1 attachment)

642.39 KB, text/plain
Details
(Reporter)

Description

4 years ago
Created attachment 8502641 [details]
log cat

Description:
Wile phone is recording, dragging down the utility bar and pressing the home button causes utility bar to lag on return to camera with utility bar text staying on after.    


Repro Steps:
1) Update a Flame to 20141008000201
2) Open camera and switch to video recording and start recording 
3) Pull down the utility bar 
4) Press home button

Actual:
lag on return to camera with utility bar text staying on after.    


Expected:
Return to camera with no lag and no text on the screen

Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
Build ID: 20141008000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Version: 34.0a2 Flame 2.1 KK (319mb)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency:100%
See attached: logcat and Video: https://www.youtube.com/watch?v=FX6-gXTMiAM
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
Issue does occur on Flame 2.2 Master KK (319mb) (Full Flash) , 

While phone is recording checking utility bar pressing the home button causes lag and text sticking issues


Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141008040203
Gaia: 0bc74ce502672cf0265b24cf3a25d117c3de5e71
Gecko: e4cfacb76830
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Issue does not occur on Flame 2.0 KK (319mb) (Full Flash)

there is no lag or text sticking after home button is pressed 


Device: Flame 2.0 KK (319mb) (Full Flash)
BuildID: 20141008000202
Gaia: 31a49c7932c7085961760a6bef9ed381ea38d7e3
Gecko: a2d707e79061
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
[Blocking Requested - why for this release]:

The Notification tray appears to be very sluggish, and poor UX is seen. Also this is a regression. Nominating this to block 2.1?
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regressionwindow-wanted

Comment 3

4 years ago
Flagging Katie to confirm expected behavior and link to the spec, for posterity. Believe this is "full screen apps should not behave this way" but defer to Katie.
Flags: needinfo?(kcaldwell)

Comment 4

4 years ago
(In reply to Stephany Wilkes from comment #3)
> Flagging Katie to confirm expected behavior and link to the spec, for
> posterity. Believe this is "full screen apps should not behave this way" but
> defer to Katie.

NI'ing Rob, he'll point us to the spec. :)
Flags: needinfo?(kcaldwell) → needinfo?(rmacdonald)
This issue separated into two different bugs.  The first is that the status bar is laggy when being brought down.  This issue is what I found the window for and occurs since the status bar was changed to be viewable during a video recording with the changes to bug 996692.

The second issue is that, when dismissed some text from the status bar remains for a short period.  As this issue seems to be a bug of a bug, I did not find a window for it.  I can if requested.

Central Regression Window:

Last Working 
Environmental Variables:
Device: Flame 2.0
BuildID: 20140502193004
Gaia: f603a1ed83fa9f17ea91795d6bc7a49cfa7b4aef
Gecko: 43c5be10eae0
Version: 32.0a1 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

First Broken
Environmental Variables:
Device: Flame 2.0
BuildID: 20140503013002
Gaia: bd97f1cfe543964baa2bb1ea0ddafa32a9c53c23
Gecko: 8d591a3f6fea
Version: 32.0a1 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: f603a1ed83fa9f17ea91795d6bc7a49cfa7b4aef
Gecko: 8d591a3f6fea

First Broken gaia / Last Working gekko - Issue DOES occur
Gaia: bd97f1cfe543964baa2bb1ea0ddafa32a9c53c23
Gecko: 43c5be10eae0

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/f603a1ed83fa9f17ea91795d6bc7a49cfa7b4aef...bd97f1cfe543964baa2bb1ea0ddafa32a9c53c23
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted

Comment 6

4 years ago
Adding Etienne for input since he fixed bug 996692
Flags: needinfo?(etienne)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
I'm not able to reproduce this on both v2.1 and master (v2.2) today using Flame-KK v184 (319mb).

v2.1:
Gaia-Rev        379ea4c9dd6d3f8ca2f79ce59c15f6afe6e557c3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/4853208cb48a
Build-ID        20141015001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141009.071519
FW-Date         Thu Oct  9 07:15:28 EDT 2014
Bootloader      L1TC00011840

master (v2.2):
Gaia-Rev        5f1f0960ae9d22acf2a324ad37a48174d6df87f6
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/62f0b771583c
Build-ID        20141015040201
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141009.071519
FW-Date         Thu Oct  9 07:15:28 EDT 2014
Bootloader      L1TC00011840

Comment 8

4 years ago
Same here, I tried with latest build on 2.1 (flame kk) and don't see the lag. 

Gaia-Rev        379ea4c9dd6d3f8ca2f79ce59c15f6afe6e557c3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/4853208cb48a
Build-ID        20141015001201
Version         34.0
Device-Name     flame-kk
FW-Release      4.4.2
FW-Incremental  34


Please reopen if this is still an issue
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(etienne)
Resolution: --- → WORKSFORME

Updated

4 years ago
blocking-b2g: 2.1? → ---
Flags: needinfo?(rmacdonald)
You need to log in before you can comment on or make changes to this bug.