Closed Bug 1080799 Opened 7 years ago Closed 7 years ago

Connecting to/joining (hidden?) Wi-Fi fails after factory resetting phone/first run, restart required

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 affected, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

RESOLVED FIXED
2.1 S7 (24Oct)
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: aryx, Assigned: mancas)

References

Details

(Keywords: regression)

Attachments

(7 files, 3 obsolete files)

[Blocking Requested - why for this release]:

Geeksphone Keon with Boot2Gecko 2.2.0.0-prerelease 20141009012329
Flame on 2.2.0.0-prerelease 20141009040206 (Kitkat)
Flame on 2.1.0.0-prerelease 20141009000203 (Kitkat)

After resetting the phone, joining a hidden network on first run from the Settings app fails (no error message, no status indicator and no connectivity). Joining a hidden network from the First Run app is broken anyway.

After a restart, entering the Wi-Fi credentials connects to the network.

This is a regression, the last version I flashed before was 2.1.0.0 20141004000205 on Flame (Kitkat) and I don't think that I restarted the device before joining Wi-Fi, so it must have regressed after that on 2.1/aurora.
Sending to the qa wanted team to find the regression window.
Unable to reproduce the bug on Flame 2.2 and Flame 2.1.

Observed behavior: I was able to connect to a hidden wifi network via Settings app right after factory resetting the phone.

I did notice that the 'Join' hidden wifi button on FTU/FTE is NOT responsive when tapped on which seems to break the device's ability to join the same hidden network later via Settings, until reboot. Maybe it had something to do with how the original reporter encountered the bug. This particular issue affects both 2.2 and 2.1.

Device: Flame 2.2 Master (shallow flash)
BuildID: 20141011031924
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame 2.1 (shallow flash)
BuildID: 20141011094725
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: 65c0a4f2b0e9
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Needinfo the reporter to confirm the behavior of the bug.
Flags: needinfo?(archaeopteryx)
I didn't tap the button to join hidden network in FTE because that's broken anyway. On first run after flashing the base image and then gaia and B2G, joining the Wi-Fi from Settings in the first boot session worked. Resetting the phone and trying to join the hidden Wi-Fi after that in the first boot session after resetting doesn't work (no Wi-Fi icon in status bar, browser has no connection).

Tested with Flame B2G 2.1 20141011160202 (Gaia commit f5d4ff60).
Flags: needinfo?(archaeopteryx)
I was unable to reproduce this issue on the latest 2.1 Flame KK, 2.2 Flame KK, or the build mentioned in comment 3 (full and shallow flash) after 3 attempts using the steps in comment 3 on each build.  

Archaeopteryx: Was this only reproduced on a Keon device with a flame build?  Any more information you might have that could help narrow down this issue would be helpful.

Environmental Variables (shallow flash):
Device: Flame 2.2
BuildID: 20141011132225
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Version: 35.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Environmental Variables (shallow flash):
Device: Flame 2.1
BuildID: 20141011150624
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: e96a7a4f3bbe
Version: 34.0a2 (2.1) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables (full flash):
Device: Flame 2.1
BuildID: 20141011160202
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: e96a7a4f3bbe
Version: 34.0a2 (2.1) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables (shallow flash):
Device: Flame 2.1
BuildID: 20141011160202
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: e96a7a4f3bbe
Version: 34.0a2 (2.1) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(jmitchell)
Flags: needinfo?(archaeopteryx)
This issue is looking to be Keon specific - which our team does not have
Flags: needinfo?(jmitchell)
The issue is not Keon specific. I can send you a logcat, please tell me to whom. I don't want to post my Wi-Fi information online.
Flags: needinfo?(archaeopteryx)
I also encounter the same problem as mentioned in comment 2 using m-c and gaia/master. The 'Join' hidden wifi button on FTU/FTE is NOT responsive when tapped on which seems to break the device's ability to join the hidden network. I think it's FTU/FTE problem and not related to wifi.
Component: Wifi → Gaia::First Time Experience
Assignee: nobody → b.mcb
The problem was that we were adding a non MozWifiNetwork object to the list of available networks. This causes crashes when trying to check if the user is connected to that network, and other checks.
Attachment #8505304 - Flags: review?(fernando.campo)
Comment on attachment 8505304 [details] [review]
Join hidden button fixed

Checked the code. Looks nice (thanks for spotting it), but we need to make tests for this. At least check that the network is ok and the button works.
Attachment #8505304 - Flags: review?(fernando.campo)
Comment on attachment 8505304 [details] [review]
Join hidden button fixed

Hey Fernando! The unit tests, for this part, have been added, please take a look

Thanks!
Attachment #8505304 - Flags: review?(fernando.campo)
2.1+ because no regressions = better.
blocking-b2g: 2.1? → 2.1+
Comment on attachment 8505304 [details] [review]
Join hidden button fixed

Many thanks for the tests Manuel, great job :)
Attachment #8505304 - Flags: review?(fernando.campo) → review+
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/edbce405a3dc087520df73207e204dc9a8d0f803
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S7 (24Oct)
Please nominate this patch for Gaia v2.1 approval when you get a chance.
Flags: needinfo?(b.mcb)
Attached file Patch for v2.1
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): No regression
[User impact] if declined: Hight, the button to join a hidden network is not responsive
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: No
Flags: needinfo?(b.mcb)
Attachment #8509423 - Flags: approval-gaia-v2.1?
Attachment #8509423 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
The issue still occurs on 2.1 Flame and Flame 2.2
Unable to connect to hidden network from "Settings" (no status indicator and no connectivity)

Steps to reproduce:
1. Open Wifi in "Settings"
2. Navigate to "Manage networks" and tap "Join hidden network"
3. Enter "SSID network name" and "Password"
4. Verify the hidden network appears on the "Wifi" page
5. Go back to "Hidden Network menu" and tap the choosing network from "Known networks"
6. Confirm to forget network
7. Log in with the "hidden network" again.
8. Go back to "Wifi" page and observe the screen

Actual:
Unable to connect with no status connectivity

Expected: 
Able to connect every time, when reconnecting

Device: Flame 2.1 KK
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master
BuildID: 20141024040202
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
Attached file logcat.txt
This bug has been verified to fail on Flame 2.1 and Flame 2.2.

Unable to connect to hidden network from "Settings" (no status indicator and no connectivity).
See the attachments: Verify_Video_Flame v2.1.MP4 and logcat.txt
Occurrence time:10:00
Occurrence rate:5/5

Issue steps:
1. Launch Settings and enter Wifi.
2. Navigate to "Manage networks" and tap "Join hidden network"
3. Enter "SSID network name" and "Password"
4. Verify the hidden network appears on the "Wifi" page
5. Go back to "Hidden Network menu" and tap the choosing network from "Known networks"
6. Confirm to forget network
7. Enter "hidden network" page and connect the hidden network again.
8. Go back to "Wifi" page and observe the screen.

Actual result:
Unable to connect with no status connectivity.

Expected result: 
Able to connect the hidden network every time.

Note: 1.Refresh all the available networks -> select the hidden network ->connect the network ->refresh all the available networks again, the hidden network can be connected in Settings.
2.In FTE, it will show "connecting..." all the time when user connect the hidden network.

Flame 2.1 version:
Gaia-Rev        8ae086c39011bc8842b2a19bb5267906fa22345a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebbd5c65c3c1
Build-ID        20141124094013
Version         34.0

Flame 2.2 version:
Gaia-Rev        aad40f6d6eb8f626c6a20db55b9f00d2e832f113
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/be4ba3d5ca9a
Build-ID        20141124100136
Version         36.0a1
Flags: needinfo?(hlu)
Hi Wesley,
    According to comment 21, the patch was landed on v2.1, but we still could reproduce this issue on flame v2.1 and v2.2. Could you please provide your suggestion that we should file another issue for tracking this bug or reopen this one? Thank you very much.
Flags: needinfo?(hlu) → needinfo?(whuang)
We seem to have at least 2 different bugs getting conflated here. There was the issue of the non-functional 'join hidden network' button in FTU. That was fixed, verified and uplifted to 2.1. Then there's the ability to actually join a hidden wifi network in FTU (vs. just the ability to tap the button to get to the screen where you enter network details). But the steps in comment #18 seem to be about joining a hidden network from the Settings app and not the FTU app at all? Can we take that into a new bug so we don't create further confusion or even backing out good patches?
Forwarding post-CC triage of 2.1 to TAM - Wesly.
Also ni to Candice for systemsfe.
Flags: needinfo?(whuang)
Flags: needinfo?(wehuang)
Flags: needinfo?(cserran)
Flags: needinfo?(cserran)
Hi Hubert:

per history above I support comment#21 that we have 2 different user scenario here, one is fixed (the FTU one) while the other is not yet (the "setting" one), personally I would suggest a new bug for the later unless we want to modify the issue title, which is more like focus on the 1st case during FTU.

BTW just to clarify I'm currently taking care of 2.0 Triage instead of 2.1.
Flags: needinfo?(wehuang)
Flags: needinfo?(hlu)
Josh, I think v2.0m need this bug.
blocking-b2g: 2.1+ → 2.0M?
Attached file PR for v2.0m
Luke, Thanks for create the patch for v2.0m.
Hi Kai-Zhen, 
2.0M+, Thanks!
blocking-b2g: 2.0M? → 2.0M+
Flags: needinfo?(hlu) → needinfo?(kli)
This bug has been failed verified on Flame v2.1 as same as Comment 18.
See attachments: flame2.1_1302.mp4 and logcat_flame2.1_1302.txt.
Reproduce rate: 5/5

-------------------------------------------------------------------------
This bug has been successfully verified on Woodduck v2.0 and Flame v2.0&2.2.But the Flame v2.0's "Tracking Flags:" is "affected".
Hi Peipei,
    Could you help to confirm this bug about Flame 2.0?

Thank you!


See attachment: verified_v2.0m.MP4.
Reproduce rate: 0/5
STR:
1. Go to Settings->Wifi.
2. Navigate to "Manage networks" and tap "Join hidden network".
3. Enter "SSID network name" and "Password".
**The hidden network(SSID:"79") is connected successfully.
4. Confirm to forget the network.
5. Log in with the "hidden network" again.
6. Go back to "Wifi" page.
**The hidden network is connected successfully.

Woodduck 2.0 build:
Gaia-Rev        ddb406ebdb34ca6717eda14297dea98f26f1f412
Gecko-Rev       e5f7072da9a640b8e63d3e25741e99f48d8a431b
Build-ID        20150113050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1421096736
FW-Date         Tue Jan 13 05:06:01 CST 2015

Flame 2.0 build:
Gaia-Rev        31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/a05a5378cb1f
Build-ID        20150112000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150112.034955
FW-Date         Mon Jan 12 03:50:06 EST 2015
Bootloader      L1TC000118D0

Flame 2.1 build:
Gaia-Rev        1975241ac29f723479e6c60b2bf74ebed54da91a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0863fe4b75c3
Build-ID        20150112001215
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150112.035023
FW-Date         Mon Jan 12 03:50:34 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c37b89bdd86
Build-ID        20150112153951
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150112.194842
FW-Date         Mon Jan 12 19:48:52 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(pcheng)
Attached video flame2.1_1302.mp4 (obsolete) —
Attached video verified_v2.0m.MP4 (obsolete) —
Shally, The problem fixed in this bug is : the 'Join' hidden wifi button on FTU/FTE is NOT responsive when tapped on.

Your steps is different. Please verify this bug by join hidden wifi in FTU. And file another bug for the join hidden wifi in Settings case.

(In reply to Shally from comment #28)
> This bug has been failed verified on Flame v2.1 as same as Comment 18.
> See attachments: flame2.1_1302.mp4 and logcat_flame2.1_1302.txt.
> Reproduce rate: 5/5
> 
> -------------------------------------------------------------------------
> This bug has been successfully verified on Woodduck v2.0 and Flame
> v2.0&2.2.But the Flame v2.0's "Tracking Flags:" is "affected".
> Hi Peipei,
>     Could you help to confirm this bug about Flame 2.0?
> 
> Thank you!
Flags: needinfo?(pcheng) → needinfo?(lixia)
(In reply to Peipei Cheng from comment #32)
> Shally, The problem fixed in this bug is : the 'Join' hidden wifi button on
> FTU/FTE is NOT responsive when tapped on.

Hi Peipei,

    Sorry to wrong understand about Comment 18 & Comment 23.
    First,this bug("Join" button in FTU) is duplicated with Bug 1120267 ( Comment 9 of Bug 1107015),but Bug 1120267 is not fixed now.
    Only verify this ("Join" hidden wifi button in FTU):
 1.This bug has been successfully verified on Flame v2.1 and woodduck 2.0(The "Join" button works normally).
   See attachments: verified_v2.0m&2.1.MP4.
   Reproduce rate: 0/3.

 2.On Flame v2.2,I can't input the password in FTU because it is blocked of the new bug 1120792.


> And file another bug for the join hidden wifi in Settings case.

   I will submit a new bug and note this bug number later.
Flags: needinfo?(lixia) → needinfo?(pcheng)
Attachment #8547973 - Attachment is obsolete: true
Attachment #8547967 - Attachment is obsolete: true
Attachment #8547964 - Attachment is obsolete: true
The new bug for the join hidden network in Settings is Bug 1120876.
See Also: → 1120876
Flags: needinfo?(pcheng)
This bug has been verified as pass on latest Nightly build of Flame v2.2 by the STR in Comment 0.

Actual results: Can join/connect a hidden Wi-Fi successfully in FTU after factory resetting phone/first run.
See attachment: verified_v2.2.mp4
Reproduce rate: 0/5


Device: Flame 2.2 build(Pass)
Build ID               20150506002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3af6a0a79227
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.040209
Firmware Date          Wed May  6 04:02:20 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage+][failed-verification][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.