Tabs Not Clearing When Browser Window is Maximized

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: firexross, Unassigned)

Tracking

33 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8502820 [details]
Closed Tabs.jpg

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141002185629

Steps to reproduce:

I closed tabs when Firefox window is maximized. The problem does not occur when the window is less than full screen.


Actual results:

fragments of tabs remain; file attached where the last three tabs shown are actually CLOSED yet they appear open. Sometimes this shows as a garbled mess.


Expected results:

tabs closed should disappear like they used to; This beta version was used to check if it was cleared up. It has been happening for the last two versions that I know of.

Comment 1

4 years ago
Hello

Is it reproducible:
1) in safe mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
2) with a clean profile: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(firexross)
(Reporter)

Comment 2

4 years ago
Hi

Yes, reproducible in Safe Mode

Yes, reproducible with a clean profile.
Flags: needinfo?(firexross)

Comment 3

4 years ago
Maybe graphics issue.
Could you type about:support in the location bar and paste the section "graphics".
(Reporter)

Comment 4

4 years ago
Graphics
Adapter Description	AMD Radeon R9 200 Series
Adapter Drivers	aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	2048
Device ID	0x6811
Direct2D Enabled	true
DirectWrite Enabled	true (6.3.9600.17111)
Driver Date	9-15-2014
Driver Version	14.301.1001.0
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon R9 200 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0

Comment 5

4 years ago
OMTC is enabled (it's new since FF33), open about:config and set layers.offmainthreadcomposition.enabled to false, restart FF33 and test again.
(Reporter)

Comment 6

4 years ago
Do not know what OMTC is, but this wouldn't explain why this has been happening for the last few releases. Anyway, changed as you suggested. No change: same problem.

Comment 7

4 years ago
Ok, I forgot that, I thought it was present only since FF33.
If it was present in the past, there is the tool mozregression (see http://mozilla.github.io/mozregression/) to find a regression range, especially as you're able to reproduce the issue.
Keywords: regressionwindow-wanted
Paul, lots of graphics changes have been made since Fx33. Is this something you still see happening?
Flags: needinfo?(firexross)
(Reporter)

Comment 9

3 years ago
Nope, problem is gone.
Flags: needinfo?(firexross)
Thanks for the quick reply!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.