toolkit/library/target fails to link on Xulrunner MacOSX 10.8 Opt builds

RESOLVED FIXED in Firefox 34

Status

--
blocker
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

(Depends on: 1 bug)

unspecified
mozilla36
x86_64
macOS
Dependency tree / graph

Firefox Tracking Flags

(firefox34+ fixed, firefox35+ fixed, firefox36 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
The same as below happens on xulrunner nightlies. This affects current aurora and m-c. (We really should make it die for good... or at the very least unhide the jobs on tbpl/treeherder, because we usually don't notice until it's too late and we don't have SDKs anymore ; this time we're lucky)

+++ This bug was initially created as a clone of Bug #1054738 +++

When building TB on MacOSX 10.8 opt get the following:
Executing: /usr/local/bin/ccache ../../../../../clang/bin/clang++ -arch i386 -Qunused-arguments -Qunused-arguments -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Werror=int-to-pointer-cast -Werror=type-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option -Wno-return-type-c-linkage -isysroot /Developer/SDKs/MacOSX10.7.sdk -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -DNO_X11 -pipe -DNDEBUG -DTRIMMED -g -O3 -fno-omit-frame-pointer -fPIC -o XUL -Wl,-filelist,/builds/slave/tb-c-cen-osx64-000000000000000/build/objdir-tb/i386/mozilla/toolkit/library/tmp2Dr0ES.list -framework Cocoa -lobjc -framework AudioToolbox -framework ExceptionHandling -Wl,-executable_path,/builds/slave/tb-c-cen-osx64-000000000000000/build/objdir-tb/i386/mozilla/dist/bin -Wl,-dead_strip ../../js/src/libjs_static.a ../../js/src/libjs_static.a ../../xpcom/typelib/xpt/libxpt.a ../../intl/unicharutil/util/internal/libintl_unicharutil_util_internal.a ../../security/nss/lib/crmf/libcrmf.a ../../js/src/libjs_static.a ../../intl/icu/target/lib/libicui18n.a ../../intl/icu/target/lib/libicuuc.a ../../intl/icu/target/lib/libicudata.a ../../config/external/nss/libnss3.dylib ../../ldap/sdks/c-sdk/ldap/libraries/libldap/libldap60.dylib ../../ldap/sdks/c-sdk/ldap/libraries/libldif/libldif60.dylib ../../ldap/sdks/c-sdk/ldap/libraries/libprldap/libprldap60.dylib ../../memory/mozalloc/libmozalloc.dylib -dynamiclib -install_name @executable_path/XUL -compatibility_version 1 -current_version 1 -single_module -L/builds/slave/tb-c-cen-osx64-000000000000000/build/objdir-tb/i386/mozilla/dist/lib -lmozglue -lm -Wl,-framework,CoreLocation -Wl,-framework,QuartzCore -Wl,-framework,Carbon -Wl,-framework,CoreAudio -Wl,-framework,AudioToolbox -Wl,-framework,AudioUnit -Wl,-framework,AddressBook -Wl,-framework,OpenGL -framework Cocoa -framework AudioToolbox -framework OpenGL -framework SystemConfiguration -framework QTKit -framework IOKit -F/System/Library/PrivateFrameworks -framework CoreUI -lcups
/builds/slave/tb-c-cen-osx64-000000000000000/build/objdir-tb/i386/mozilla/toolkit/library/tmp2Dr0ES.list:
    StaticXULComponentsStart.o
.
.
.
ld: bad codegen, pointer diff in __ZN21XPCWrappedNativeScopeC2EP9JSContextN2JS6HandleIP8JSObjectEE to global weak symbol __ZTVN2JS10WeakMapPtrIP8JSObjectS2_EE for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[7]: *** [XUL] Error 1
make[6]: *** [toolkit/library/target] Error 2

Works fine for MacOSX 10.8 debug
(Assignee)

Updated

5 years ago
Summary: toolkit/library/target fails to link on Thunderbird MacOSX 10.8 Opt builds → toolkit/library/target fails to link on Xulrunner MacOSX 10.8 Opt builds
(Assignee)

Updated

5 years ago
status-firefox34: --- → affected
status-firefox35: --- → affected
(Assignee)

Updated

5 years ago
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED

Updated

5 years ago
Attachment #8503034 - Flags: review?(benjamin) → review+
Duplicate of this bug: 1060995
It's actually beyond critical, since the SDK is a release deliverable, and this bustage is on beta, which builds releases. Builds one pretty darn soon, too.

[Tracking Requested - why for this release]:

Drivers: just housekeeping moving the flag here, you already plussed it for 34 in bug 1060995, but it wound up with an independently-noticed fix here instead.
Severity: critical → blocker
tracking-firefox34: --- → ?
(Assignee)

Updated

5 years ago
Whiteboard: [npotb][checkin-needed-aurora][checkin-needed-beta]
https://hg.mozilla.org/mozilla-central/rev/83124759043f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
per lmandel on IRC, we will not rebuild 34.0b1 to pick up this fix, but would like it for 34.0b2 early next week.
(In reply to Nick Thomas [:nthomas] from comment #6)
> per lmandel on IRC, we will not rebuild 34.0b1 to pick up this fix, but
> would like it for 34.0b2 early next week.

Correct. Please commit Thursday or Friday this week so that we're set for beta2.
tracking-firefox34: ? → +
tracking-firefox35: --- → +
https://hg.mozilla.org/releases/mozilla-aurora/rev/34f6b3245d5d
https://hg.mozilla.org/releases/mozilla-beta/rev/5967c4a96835
status-firefox34: affected → fixed
status-firefox35: affected → fixed
status-firefox36: --- → fixed
Whiteboard: [npotb][checkin-needed-aurora][checkin-needed-beta]
Target Milestone: mozilla35 → mozilla36
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.