Linkify commit SHAs and Github PR/compare links in commit messages

RESOLVED FIXED

Status

Tree Management
Treeherder
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: zac, Assigned: mishravikas)

Tracking

({regression})

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
On Gaia-Try in TBPL, the string " Gaia PR#24657" was turned into a link to that pull request.

We haven't carried over this feature to the new Treeherder Gaia-Try but it would be nice to.

Updated

3 years ago
Blocks: 1059400
Depends on: 1028496
OS: Linux → All
Priority: -- → P2
Hardware: x86_64 → All
Summary: Gaia-Try jobs on Treeherder don't link straight to the Github PR → Linkify Github compare links in commit messages

Comment 1

3 years ago
In fact, we've also regressed turning "changeset abcdef123" into a link too.

TBPL:
https://hg.mozilla.org/webtools/tbpl/file/547a7de112ac/js/UserInterface.js#l764

Treeherder:
https://github.com/mozilla/treeherder-ui/blob/66d22cde71cd5923d3853b4a33a17e7a75571144/webapp/app/js/directives/clonejobs.js#L378
https://github.com/mozilla/treeherder-ui/blob/ce17b1f729b866c8f7976fa4974493a90f4d550c/webapp/app/js/filters.js#L36
Summary: Linkify Github compare links in commit messages → Linkify commit SHAs and Github compare links in commit messages

Updated

3 years ago
Summary: Linkify commit SHAs and Github compare links in commit messages → Linkify commit SHAs and Github PR/compare links in commit messages

Updated

3 years ago
Duplicate of this bug: 1091032

Updated

3 years ago
Keywords: regression
Created attachment 8556521 [details] [review]
Link to treeherder-ui PR #351

camd, can you review this?
Attachment #8556521 - Flags: review?(cdawson)
Comment on attachment 8556521 [details] [review]
Link to treeherder-ui PR #351

I'll take this one.
Attachment #8556521 - Flags: review?(cdawson) → review?(wlachance)
Comment on attachment 8556521 [details] [review]
Link to treeherder-ui PR #351

Good start, but I think this one needs a bit more work before it can be merged in. See the PR for more details.
Attachment #8556521 - Flags: review?(wlachance) → review-
Comment on attachment 8556521 [details] [review]
Link to treeherder-ui PR #351

This was fixed and it looks good now!
Attachment #8556521 - Flags: review- → review+
Closing this out.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Thank you for fixing this :-)
Assignee: nobody → vikasmishra95

Updated

3 years ago
Depends on: 1133021
You need to log in before you can comment on or make changes to this bug.